Forum Replies Created

Viewing 30 posts - 1 through 30 (of 42 total)
  • Author
    Posts
  • in reply to: Some customisations not working after last edit #650135

    Hi Josue…

    I forgot the option that these missing elements could not be missing due to the latest edit u did related to the pagination.
    I just noticed at a later stage.
    It is probably related to some hard coded cutomisation directly to an old parent theme …which I got rid while cleaning the themes folder from unnecessary stuff.
    I solved no.3 by including the modified file to the parent theme, under includes/helper-templates.php.
    But I cant find how to add the symbols (no.1 & no.2) in the meta fields.

    Any advice..?

    Excellent…!!!
    It works fine now.
    Grateful for the support and many thanks for the extra mile.
    You got me out of a stressful situation.
    Happy man…!

    Be well Josue.
    Regards.

    Vasileios

    Hi Josue…

    Thanks for pointing out again.
    The developer that did the customisation is nowhere to be found…
    So could you show me what you changed so I can repeat it later (or a backup file named Josue or something), and revert back to the state it was yesterday?
    I cant leave the site like this until I sort out the JQuery code thing.
    It might not looked well, but one could flick through the portfolio pages.

    I will look into updating JQuery on my own if I can.
    Will have to do some reading.
    Otherwise I will have to find some other developer to do it.

    Many thanks though, for everything.

    Be well.

    Vasileios

    Hi again…and a good new day.

    As I mentioned last night, after the latest edits (Josue) the pagination looks fine, but it is not working properly.
    Only the first page gives results.
    All following pages show 0.

    It cannot stay like that for long, at least during the day.
    Please look into it asap.

    Thank u.

    Vasileios

    My dear man Josue…!
    Thanks for looking into this.
    Almost fixed…
    It looks right …but cannot go to the second page of results now..

    Hey Josue…
    Here are the FTP details…

    Thanks Josue for pointing out.

    I ve looked over the file again and again and I cant find what generates this structure that looks like an open <div> that is missing the </div>
    As it appears on the front end https://gyazo.com/3f9fcec57f4e0a88eada930416751c64

    I also tried to delete/rename the file (under angular-child) temporarily …but nothing changed in the front end..!
    I only have a very basic understanding of PHP…but since I disable the edited file under the child theme, shouldn’t it work properly?

    Lastly, my concern is that the pagination worked fine before the latest updates in WP4.5 and Angular4.1.
    Is there something obvious to u what is causing this and how to fix it..?

    Kind thanks.
    Vasileios

    Sure..
    Here are the new ones,

    Hi Rikard.
    Thanks for replying.

    Let me know if these still work.

    in reply to: Problem with upgrading to WP4.5 #643033

    I found something…although not solved it yet.

    In angular-child/includes/loop-portfolio.php there is one line that makes all the difference.
    It is marked by SmartInfoSys and it calls the avia_pagination.
    The result on the front end is this: https://gyazo.com/3f9fcec57f4e0a88eada930416751c64
    The line of code is this:

    if(!isset($avia_config['remove_pagination'] ))
    	{		
    		echo "<div class='hr hr_invisible'></div>";
    		/* STRAT: modified by smartinfosys */
    		echo avia_pagination('',true);	
    		/* END: modified by smartinfosys */	
    	}
    	?>

    Now, in the parent theme file the line is echo avia_pagination();
    And when I substitute the line in the child theme with thisone, the pagination appears as it should appear …but when clicked to go to the second page the result is ‘0’ and no portfolio items appear: https://gyazo.com/a57f43d76366b231f5f62e94f7e2d2ec

    So, where is that avia_pagination structured and why this (”,true) thing make so much difference..?
    Could u please help me out here…?
    I am so close to fixing this troublesome issue.
    And as I mentioned before, this was no issue before upgrading to WP4.5 and Angular v4.1.

    Any advice welcomed.

    in reply to: Problem with upgrading to WP4.5 #642953

    Strangest thing is that when I switch to the parent theme, the portfolio pages like http://www.crete-homes.com/houses/ will not load at all.
    It appears ok in the template builder (parent theme) but the front end will not load.

    Also when I delete the above mentioned files (actually I just rename them adding TEMP at the end) from the child theme directory, I get the same result, the same not properly structured pagination.
    My logic was that if I delete the child theme file, it would just read the parent file and render out something different (without any customisation).
    But that is not the case.
    So it must be some other file giving the structure of the dynamic portfolio pages…right?
    Any ideas..?

    Thanks again.

    • This reply was modified 3 weeks, 5 days ago by  vaschops.
    in reply to: Problem with upgrading to WP4.5 #642946

    An this in angular-child/framework/php/function-set-avia-frontend.php

    /* START: modified by smartinfosys */
    		if(1 != $pages && $ajax=='')
    		{
    			
    			$output .= "<div class='pagination'>";
    			$output .= "<span class='pagination-meta'>".sprintf(__("Page %d of %d", 'avia_framework'), $paged, $pages)."</span>";
    			$output .= ($paged > 2 && $paged > $range+1 && $showitems < $pages)? "<a href='".$method(1)."'>&laquo;</a>":"";
    			$output .= ($paged > 1 && $showitems < $pages)? "<a href='".$method($prev)."'>&lsaquo;</a>":"";
    
    			for ($i=1; $i <= $pages; $i++)
    			{
    				if (1 != $pages &&( !($i >= $paged+$range+1 || $i <= $paged-$range-1) || $pages <= $showitems ))
    				{
    					$output .= ($paged == $i)? "<span class='current'>".$i."</span>":"<a href='".$method($i)."' class='inactive' >".$i."</a>";
    				}
    			}
    
    			$output .= ($paged < $pages && $showitems < $pages) ? "<a href='".$method($next)."'>&rsaquo;</a>" :"";
    			$output .= ($paged < $pages-1 &&  $paged+$range-1 < $pages && $showitems < $pages) ? "<a href='".$method($pages)."'>&raquo;</a>":"";
    			$output .= "</div>\n";
    		}
    		/* END: modified by smartinfosys */
    		
    		/* START: added by smartinfosys */
    		if(1 != $pages && $ajax!='')
    		{
    			
    			$output .= "<div class='pagination'>";
    			$output .= "<span class='pagination-meta'>".sprintf(__("Page %d of %d", 'avia_framework'), $paged, $pages)."</span>";
    			$output .= ($paged > 2 && $paged > $range+1 && $showitems < $pages)? "<a href='".avia_get_page_link($_SESSION['page_link'],1)."'>&laquo;</a>":"";
    			$output .= ($paged > 1 && $showitems < $pages)? "<a href='".avia_get_page_link($_SESSION['page_link'], $prev)."'>&lsaquo;</a>":"";
    
    			for ($i=1; $i <= $pages; $i++)
    			{
    				if (1 != $pages &&( !($i >= $paged+$range+1 || $i <= $paged-$range-1) || $pages <= $showitems ))
    				{
    					$output .= ($paged == $i)? "<span class='current'>".$i."</span>":"<a href='".avia_get_page_link($_SESSION['page_link'],$i)."' class='inactive' >".$i."</a>";
    				}
    			}
    
    			$output .= ($paged < $pages && $showitems < $pages) ? "<a href='".avia_get_page_link($_SESSION['page_link'],$next)."'>&rsaquo;</a>" :"";
    			$output .= ($paged < $pages-1 &&  $paged+$range-1 < $pages && $showitems < $pages) ? "<a href='".avia_get_page_link($_SESSION['page_link'],$pages)."'>&raquo;</a>":"";
    			$output .= "</div>\n";
    		}
    		/* END: added by smartinfosys */
    in reply to: Problem with upgrading to WP4.5 #642945

    The above was the angular-child/includes/loop-portfolio.php

    in reply to: Problem with upgrading to WP4.5 #642941

    Hey Basilis..
    Thanks for replying..

    I am trying to find the file to edit.
    The parent theme is clean (as released) so it must be a modified file in child theme.
    I found the below edited file that seems to have the relevant mods, but I cant work it out.

    Anything u can locate?

    <?php 
    /*
    * The Loop for portfolio overview pages. Works in conjunction with the file template-portfolio.php and taxonomy-portfolio_entries.php
    */
    
    global $avia_config;
    $avia_config['avia_is_overview'] = true;
    
    if(isset($avia_config['new_query'])) { query_posts($avia_config['new_query']); }
    
    $loop_counter = 1;
    // check if we got a page to display:
    if (have_posts()) :
    	
    	$extraClass = 'first';
    	$style = 'portfolio-entry-no-description';
    	
    	$grid = 'one_fourth';
    	$image_size = 'portfolio';
    
    	
    	
    	switch($avia_config['portfolio_columns'])
    	{
    		case "1": $grid = 'fullwidth';  $image_size = 'fullsize'; break;
    		case "2": $grid = 'one_half';   break;
    		case "3": $grid = 'one_third';  break;
    		case "4": $grid = 'one_fourth'; break;
    	}
    	
    	$avia_config['portfolio_columns_iteration'] = $avia_config['portfolio_columns'][0];
    	if(!isset($avia_config['remove_portfolio_text'])) $style = 'portfolio-entry-description';
    	
    	
    	$includeArray = "";
    	if(isset($avia_config['new_query']['tax_query'][0]['terms'])) $includeArray = $avia_config['new_query']['tax_query'][0]['terms'];
    	
    	
    	$args = array(
    	
    		'taxonomy'	=> 'portfolio_entries',
    		'hide_empty'=> 0,
    		'include'	=> $includeArray
    	
    	);
    	
    	$categories = get_categories($args);
    	$container_id = "";
    	
    	
    	if(!isset($avia_config['portfolio_sorting']) || $avia_config['portfolio_sorting'] == 'yes')
    	{
    		if(!empty($categories[0]))
    		{
    			$output = "<div id='js_sort_items' >";
    	
    			$hide = "hidden";
    			if (isset($categories[1])){ $hide = ""; }
    			
    			$output .= "<div class='sort_by_cat $hide '>";
    			$output .= "<a href='#' data-filter='all_sort' class='all_sort_button active_sort'>".__('All','avia_framework')."</a>";
    			
    			foreach($categories as $category)
    			{
    				$output .= "<span class='text-sep ".$category->category_nicename."_sort_sep'>•</span><a href='#' data-filter='".$category->category_nicename."_sort' class='".$category->category_nicename."_sort_button' >".$category->cat_name."</a>";
    				$container_id .= $category->term_id;
    			}
    			
    			$output .= "</div>";
    			
    			$output .="<div class='loadingajax'><img src='".AVIA_BASE_URL."/images/layout/loading.gif' /></div>";
    			$output .= "</div>";
    			
    			echo $output;
    		}
    	}
    	
    	//portfolio container
    	echo "<div class='ajax-portfolio-response-wrapper'>";
    	echo 	"<div class='ajax-control'><a href='#' class='ajax-close'><span>x</span></a><a href='#' class='ajax-next'><span>></span></a><a href='#' class='ajax-prev'><span><</span></a></div>";
    	echo 	"<div class='ajax-portfolio-response'></div>";
    	echo "</div>";
    	
    /* START: added by smartinfosys */
    global $paged;
    $limit = $avia_config['portfolio_item_count'];
    $pagenum = get_query_var('paged');
    $paged = $pagenum;
    $offset = $pagenum > 0 ? ($pagenum-1)*$limit : 0;
    $type= 'post';
    ?>
    <input type="hidden" name="limit" id="limit" value="<?php echo $limit; ?>" />
    <input type="hidden" name="offset" id="offset" value="<?php echo $offset; ?>" />
    <input type="hidden" name="include" id="include" value='<?php echo serialize($includeArray); ?>' />
    <input type="hidden" name="baseurl" id="baseurl" value="<?php echo esc_url( site_url( '/' ) ); ?>" />
    <input type="hidden" name="portfolio_columns" id="portfolio_columns" value="<?php echo $avia_config['portfolio_columns']; ?>" />
    <input type="hidden" name="portfolio_columns_iteration" id="portfolio_columns_iteration" value="<?php echo $avia_config['portfolio_columns_iteration']; ?>" />
    <input type="hidden" name="remove_portfolio_text" id="remove_portfolio_text" value="<?php echo $avia_config['remove_portfolio_text']; ?>" />
    <input type="hidden" name="portfolio_ajax" id="portfolio_ajax" value="<?php echo $avia_config['portfolio_ajax']; ?>" />
    <input type="hidden" name="AVIA_BASE_URL" id="AVIA_BASE_URL" value="<?php echo AVIA_BASE_URL; ?>" />
    <?php	
    
    /* END: added by smartinfosys */
    	
    	echo "<div class='portfolio-sort-container ".$avia_config['portfolio_hover']."'>";	
    	//iterate over the posts
    	while (have_posts()) : the_post();	
    	
    	//get the categories for each post and create a string that serves as classes so the javascript can sort by those classes
    	$sort_classes = "";
    	$item_categories = get_the_terms( $id, 'portfolio_entries' );
    
    	if(is_object($item_categories) || is_array($item_categories))
    	{
    		foreach ($item_categories as $cat)
    		{
    			$sort_classes .= $cat->slug.'_sort ';
    		}
    	}
    		
    	if(!empty($avia_config['portfolio_ajax'])) $sort_classes .= " ajax_portfolio";
    	
    ?>
    
    		
    		<div data-ajax-id='<?php echo get_the_ID();?>' class='post-entry post-entry-<?php echo get_the_ID();?> flex_column all_sort no_margin <?php echo $sort_classes.' '.$grid.' '.$extraClass.' '.$style; ?>'>
    			
    			<div class='inner-entry'>										
    				<?php 
    					
    					echo "<h1 class='post-title portfolio-title'>";
    					echo "<span class='primary-background title-span'></span>";
    					echo "<a href='".get_permalink()."' rel='bookmark' title='".__('Permanent Link:','avia_framework')." ".get_the_title()."'>".get_the_title()."</a>";
    					echo "</h1>";
    					
    					//show the meta stuff
    					if (function_exists('angular_portfolio_meta'))
    						$meta = angular_portfolio_meta(get_the_ID());
    					else
    						$meta = avia_portfolio_meta(get_the_ID());
    						
    					if($meta)
    						echo $meta;
    					
    					$forceSmall = true;
    					$slider = new avia_slideshow(get_the_ID());
    					$slider -> setImageSize($image_size);
    					if(!empty($avia_config['portfolio_ajax'])) $slider -> set_links(get_permalink());
    					
    					echo $slider->display($forceSmall);
    				
    				 
    				?>		
    			</div>		        
    		<!-- end post-entry-->
    		</div>
    	
    	<?php 
    
    	$loop_counter++;
    	$extraClass = "";
    
    	if($loop_counter > $avia_config['portfolio_columns_iteration'])
    	{
    		$loop_counter = 1;
    		$extraClass = 'first';
    	}
    
    	endwhile;
    	
    	echo "</div>";	// end portfolio-sort-container
    
    	
    	
    	if(!isset($avia_config['remove_pagination'] ))
    	{
    		echo "<div class='hr hr_invisible'></div>";
    		/* STRAT: modified by smartinfosys */
    		echo avia_pagination('',true);	
    		/* END: modified by smartinfosys */	
    	}
    	?>
    	<?php
    	echo "<!-- end -->"; //dont remove
    	else: 
    ?>	
    	
    	<div class="entry">
    		<h1 class='post-title'><?php _e('Nothing Found', 'avia_framework'); ?></h1>
    		<p><?php _e('Sorry, no posts matched your criteria', 'avia_framework'); ?></p>
    	</div>
    <?php
    
    	
    
    	endif;
    	
    unset($avia_config['avia_is_overview']);		
    ?>
    
    • This reply was modified 3 weeks, 5 days ago by  vaschops.
    in reply to: Problem with upgrading to WP4.5 #642925

    • This reply was modified 3 weeks, 5 days ago by  vaschops. Reason: false comment
    in reply to: Problem with upgrading to WP4.5 #642920

    I managed to resolve the issue..!

    Had to clean up the child theme from messy previous customisations…

    One last thing is that the pagination in portfolio page now appears scrambled or something.
    But I cant locate the file to edit in order to fix this.

    Could u point me where to look…?

    in reply to: Content slider is stacking up posts after WP4.5 update #617774

    I had to revert back to WP4.4.2
    All issues mentioned above work fine now.
    Maps, filters, custom login…all good.

    I understand this is a temporary fix …and a not very secure one.
    Until a new version of Angular comes out, compatible with WP4.5

    in reply to: Content slider is stacking up posts after WP4.5 update #617659

    Hi guys…

    Could u please reply?
    Are u working on something..?
    When is it due..?

    There is pressure from my client about the website not working properly.
    I have to tell them something.

    Kind thanks

    in reply to: Content slider is stacking up posts after WP4.5 update #616677

    As far it concerns the post slider…

    I read your post (Purchase code hidden if logged out)(Purchase code hidden if logged out) -this-first/”>http://www.kriesi.at/support/topic/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) -this-first/ and copied over the code to functions.php
    The post are not stacking anymore but now the slider pagination does not show up.

    UPDATE…Portfolio images (same as sorting filters) now do not show up.
    I had to delete the code snippet from functions.php to see images again.

    • This reply was modified 2 months, 1 week ago by  vaschops. Reason: update
    in reply to: Content slider is stacking up posts after WP4.5 update #616666

    Hi guys..

    Could u please have a look and advise what might be causing the issue..?
    I apologise for the persistence, but it is kind of urgent.

    Thank u for understanding.

    in reply to: Content slider is stacking up posts after WP4.5 update #615952

    I tried to upload the latest framework folder u released, but it caused some issues in the portfolio pagination that broke up the styling of the pagination page-numbers. So I reverted to the older version and renamed the new one framework-LATEST
    I dont understand what is going on.
    It all worked fine until now, for more than a year.

    Please advise…

    in reply to: Content slider is stacking up posts after WP4.5 update #615949

    I cleaned up the old parent themes that were in themes folder. I thought they were being used by some older customisation, but I deleted them and I didn’t notice any problems.

    Below u will find the ftp details if it helps to detect any anomalies.

    For Angular updates I only update the folders your mention in the version.txt file, manually, under the angular-latest folder.
    This structure with angular-child and angular-latest was introduced by a programmer in the customisation mentioned before.
    Some framework files were modified and kept under angular-child.
    I dont know if this is causing any problems.

    Please have a look and let me know if there is something obvious to u that can be causing these issues.

    Will wait for your reply.
    Kind thanks.

    Vas

    in reply to: Content slider is stacking up posts after WP4.5 update #615942

    Another issue that occurred after WP4.5 upgrade is that the sorting filters above portfolio dont appear anymore.

    Portfolio page: http://www.crete-homes.com/houses/

    Screenshot: http://prnt.sc/ati5p2


    Additional notes:
    Since the latest WP update, we had other issues with maps inserted using MapPress plugin that are not appearing anymore in the single portfolio pages (below the text).
    I understand this is a third party plugin, but it all worked fine until now and I wonder if all issues are related with the JQuery version used by the theme.
    I tested reverting to Twenty Sixteen and for example on http://www.crete-homes.com/contact-us/ the map appears fine.
    But when I switch back to Angular the map does not appear on the page at all.

    Please advise.

    Kind thanks

    • This reply was modified 2 months, 2 weeks ago by  vaschops.
    in reply to: Content slider is stacking up posts after WP4.5 update #615928

    I thought I did send the details before…but I cant see them.
    So here they are …with a new pass.

    in reply to: Content slider is stacking up posts after WP4.5 update #613924

    I have changed the content slider on the homepage to show just 1 slide until this is fixed.

    So I created a test page…

    in reply to: Content slider is stacking up posts after WP4.5 update #613915

    Hi Yigit..

    I have uploaded the latest folders as mentioned in the latest version log.
    It might read an older version, but it has the updated folders.
    Also, due to some customisations in the past, it uses the child theme, the new latest version …and it also keeps an older theme version where it calls some functions from (!).
    I know it sounds messy.
    But it worked fine until now.
    We want to hire someone to tidy up the messy part, but that is another subject.

    So, does content slider work fine on your side for Angular..with the latest theme and WP version ?
    Is it sufficient for me to update the content of the folders js & framework that you point out, or I have to change more things…?

    Thanks…

    Vas

    in reply to: Revisions in Angular theme do not appear in screen options #341397

    Worked perfectly.
    I edited register-portfolio.php and added revisions in supports as described (Purchase code hidden if logged out) -type”>here

    Thank u Ismael.

    Theme is well structured and robust. (Although I would prefer to have started this project with Enfold).
    Is there a way to easily switch from Angular to Enfold, and copy the customisations also?
    I mean, are both themes similar/same in structure, avia framework etc?

    in reply to: Portfolio pagination appears broken #324669

    It seems I managed to get the filtering to work in both Chrome and Firefox.

    Pagination is still an issue. It will not load the next page of paginated results.
    Any advice..?

    Is it PHP based?
    Is it JQuery based?
    Files to look at..?

    in reply to: Portfolio pagination appears broken #324469

    Could u provide a more detailed log of changes in 1.9?
    It will help me track down the problem, although I am not keen on PHP.

    The thing is, that it all worked fine before upgrading to 1.9.
    And I know that changes should be transferred to the child theme.
    Although with Angular does seem to be that way.
    So if there is something u can do on your end, I would really really appreciate.

    Please reply soon.
    Kind thanks.

    • This reply was modified 1 year, 9 months ago by  vaschops.
    in reply to: Portfolio pagination appears broken #324411

    Custom changes were mostly in ‘function-set-avia-frontend.php’.

    • This reply was modified 1 year, 9 months ago by  vaschops.
Viewing 30 posts - 1 through 30 (of 42 total)