If you have troubles since the update to WordPress 4.5 please read this post before opening a new thread.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #16233

    I messed something up. On this blog I created for a lady I did a lot of changes to the css and whatnot and now when she clicks page 2 or 3 of the home page which also the blog, it puts /page/2/ on the end like it is going to the 2nd page, but nothing happens. It’s still the first page. Please message me at (Email address hidden if logged out) and I will give login details as it’s still in the development phase.


    Hi andreanapier1985,

    Try to deactive all your plugins and re-update your permalinks. If this doesn’t work, try to update the theme.




    Hey Ismael,

    I deactivated the plugins, updated the permalinks, and updated the theme. I’m wondering if it’s because the blog is on the home page??? I tried putting the blog somewhere else and it worked fine. The site is live/non-indexed. http://www.nymphotales.com/



    Hi andreanapier1985,

    I don’t think that would happen because the blog is on the homepage, however, you might want to try this out:

    Go to Choices > Theme Options and set:

    Frontpage Settings – Home

    Blog – Blog

    Go to Choices > Template Builder > Frontpage

    Add a Blog element to your frontpage template

    Just make sure that your Home’s (the page you set as frontpage) layout is set to “Frontpage” under “Dynamic Templates”.

    Hope this helps. :)




    Hmmm… I hate to keep coming back empty handed Ismael.

    Made sure this was the case and still when I go to /page/2/ on the home page, it was a duplication of the base site.

    Please write at (Email address hidden if logged out) and I will give you login details to see if there’s something in the custom CSS that is messing it up.



    You said that you modified the code causing pagination to break? I think the simplest thing would be to start with a fresh theme without any modifications on your development server and after making sure that pagination is working, to slowly start adding your modifications back until you hit the point where it breaks and work from there.






    I took the content and placed it in a fresh space elsewhere. The issue still persists.

    No tweeks, no css…



    Sorry about that, I took your intro to mean that prior to edits everything worked.

    1) Let’s try a different route – please go to Admin > Choices > Theme Options, and make sure that *both* ‘Frontpage Settings; as well as ‘And ‘where do you want to display the Blog’ settings are both identical and both are selecting the Blog page (the page currently set on site).

    Click Save. Please see if anything changed. If not:

    2) Now please go to Admin > Settings > Reading and set the Radio Button for ‘Static Page’ and select Blog page (same as 1st step).

    Please let me know how it went.




    When I did this, the blogs all showed up and the pagination worked but then the image at the top went away and that was pretty important to this woman. I’m wondering if I should do it that way but just throw the code for the image in the blog page template but not the standard page template so it wouldn’t be anywhere but the home page and subsequent paginations of that. Does that make sense?

    What do you think?



    I am not sure why the part is missing, it’s strange.You can use template builder to create a dynamic template for the homepage, add the blog , and before the blog add whatever other element you want to show whatever was there before.




    Hey, should let y’all know what worked. When I changed the reading settings to the latest posts WHILE also putting the HOME page as the blog and the home page the pagination started working again.



    Great that everything is working. Looks good.



Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘2nd & 3rd Blog Pages Don't Work’ is closed to new replies.