Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #216402

    Hello there,
    On checking the HTML code of the home page of a test site I found this huge block of CSS.
    Is it my mistake?
    How can I remove it and retreive the code from the .css file?
    Thank you.

    <edited out by Devin – enfold.css copy>

    • This topic was modified 7 months ago by  Devin.
    #216681

    Hey Cum_Vincere!

    Can we see your site live? That css should by default actually already be saved to a custom created file in your uploads folder.

    Regards,
    Devin

    #216898
    This reply has been marked as private.
    #217062

    Looks like the file to write the style options to hasn’t been created. Go to your WordPress uploads folder over FTP or through your server panel and make sure that the chmod permissions allow WordPress to create a new folder and write to it.

    Then go to the themes styling tab and make a change, then re-save the options.

    #217079

    OK Devin, thank you for your suggestion.

    I changed permissions of either /wp-content/ and /wp-content/uploads/ even to 777, went to the styling tab, changed a setting and saved, but nothing changed.

    #217449

    Hello, any other suggestion?

    Thank you.

    #217759

    Hi!

    Please go to /wp-content/uploads/ and create a new folder called “dynamic_avia” (without the quotes). Then set the folder permission to 777 and go to Enfold > Theme Options and click the “Save” button to regenerate the dynamic stylesheet.

    Best regards,
    Peter

    #219326

    Hello Peter,

    No, unfortunately nothing changed after following your procedure above. No file is created in the new folder “dynamic_avia” and the CSS block remains in the HTML.

    Actually, now it comes to my mind what follows. If I remember correctly your Enfold theme does not come with a child-theme folder.
    I created a child theme folder and all the rest worked fine.
    Can this be the reason of this malfunction?

    Thanks.

    #219378

    Hey!

    Have you tried selecting a different predefined color scheme on Enfold > Styling options? Change the color scheme then change it back.

    Cheers!
    Ismael

    #219397

    Hello Ismael,

    I tried changing the colour scheme two times, with no result.

    I also tried de-activating the /enfold-child/ theme and activating the basic /enfold/ configuration but nothing changed.

    The CSS remains in the HTML.

    #219474

    Hey!

    We’ll notify Kriesi about this. Please wait for his response.

    Regards,
    Ismael

    #220875

    Hello, any news about this question?

    Thank you.

    #220957

    Hi!
    mind posting wordpress access data and ftp data in a post that is set as private reply so I can take a look at the backend myself?

    Best regards,
    Kriesi

    #226853

    Hello Kriesi,

    Thank you for your proposal. Unfortunately our customer does not allow us to give access to his site to other people.

    What I can tell you is that the huge block of CSS is the output of / enfold / css / dynamic-css.php

    I tried to replace the /enfold/ files with the latest version (today, version 2.5) and use it without the child theme I had created: the block remains.

    I also de-activated all plugins, but nothing changed.

    What else could I try?

    Thank you.

    #227142

    Hi!

    This css output is basically the fallback solution if the theme is not allowed to read/write the folder and file that Dude mentioned before. Since the backend needs to save the color and styling rules somewhere it tries to create the file: wp-content/uploads/dynamic_avia/enfold.css

    If this file is not located on your server then the theme is probably not allowed to read or write. if it is available make sure to set the file permission of both, folder and css file to 755 or 777

    Thats pretty much the only advice I can offer without having access to your server…

    Cheers!
    Kriesi

    #227309

    Hello Kriesi,
    Thanks for your explaination and suggestions.
    I checked the state of the folders and found:

    1) wp-content/uploads/dynamic_avia/ already exists on the server
    2) Permissions for all folders was already set to 777 for the three folders
    3) in /dynamic_avia/ I found no enfold.css file
    4) I created an enfold.css file and gave it 777 access permissions
    5) I went to the theme Options section, changed a styling setting and saved
    6) I opened the newly created enfold.css file but nothing was written in there.

    I believe we are just missing one single step somewhere…

    #227360

    Hi!

    Please remove the enfold.css file that you created then try to change the predefined color scheme again. The enfold.css file should be automatically created. Make sure that the dynamic_avia/ folder is writable.

    Regards,
    Ismael

    #227382

    Hello Ismael,
    Thank you for your suggestion.
    Unfortunately the enfold.css is not created.
    Permission in /wp-content/uploads/dynamic_avia/ are all set to 777.
    I also tried deactivating the theme and re-activating it, with no result.

    #227385

    Another test I made was giving 777 permissions to /httpdocs/ (never tried before!) but nothing changed.

    #227389

    Hold on… maybe I got it… just one second.

    #227399

    OK, I fixed it.
    The problem was: in WP dashboard / Settings / Media -> “Save uploads in this folder” we had set, long time ago, a /photo/ folder, in the server root.
    Therefore, the /dynamic_avia/ folder was supposed to be created here.
    Once I created it all worked.

    Meanwhile I had made a copy of this WP test installation, just to experiment on it, and that installation contained a child theme.
    The child theme did not work properly.
    I then understood that the /dynamic_avia/zzzzz.css file for the child theme needed to be named mysite_child_theme.css (where mysite is the site name as specified in WP dashboard / Settings / General -> Site name.

    Well, I wish to thank the Kriesi staff for the kind support and hope this experience can be useful for other people in this forum.

    #227407

    Hi!

    Glad you finally fixed it. This will be noted for future reference. Thanks.

    Cheers!
    Ismael

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘A bulk CSS surprise’ is closed to new replies.