Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #13568

    Is there a way to have the “Related Products” show up in the sidebar, instead of at the bottom of product pages?

    I’ve removed the cart functions with the WooCommerce Catalog Visibility Options plugin and received support on how to remove the animated “Add to Cart” button. Is there a way to keep the “Show Details” button from animating? Without the “Add to Cart” button, the animation seems unnecessary.

    Is there a way to make the white background on product pages transparent without making the product image transparent?

    I’ve uploaded all my product images at 1620px so that they look crisp in the background gallery on the product pages, but those same images look fuzzy in the product gallery because they’re being scaled down so much. Does the Flashlight template not create 2 versions of those images so they look great in both places? Before I had them sized for the product gallery and they looked fuzzy in the background. What’s the best method here?

    Since there is no way to subscribe to forum posts, is there a way to look up your own posts. I get no notifications when posts are answered.

    Thanks in advance for any solutions. This is the big push to get this live. Here is the site as it is: http://www.boggscollective.com/boggs_version2

    #79726

    Just realized that when I “hide sidebar & content” the right sidebar doesn’t hide. Example: http://www.boggscollective.com/boggs_version2/product/two-end-tables/

    #79727

    Hi Balero98,

    For the first one, if you would like to remove the button and then have the image be a link to the item instead you can try the following:

    Open up woocomerce-config>config.php and search for:

    echo get_the_post_thumbnail( get_the_ID(), 'shop_catalog' );
    echo $link;
    echo "<a class='button show_details_button $extraClass' href='".get_permalink($post->ID)."'>".__('Show Details','avia_framework')."</a>";
    if(!empty($rating)) echo "<span class='rating_container'>".$rating."</span>";

    Replace it with:

    echo "<a href='".get_permalink($post->ID)."'>".get_the_post_thumbnail( get_the_ID(), 'shop_catalog' )."</a>";
    #echo get_the_post_thumbnail( get_the_ID(), 'shop_catalog' );
    echo $link;
    #echo "<a class='button show_details_button $extraClass' href='".get_permalink($post->ID)."'>".__('Show Details','avia_framework')."</a>";
    #if(!empty($rating)) echo "<span class='rating_container'>".$rating."</span>";

    You could use rgba value to get a semi transparent or completely transparent background on your product pages. You can use the following CSS for that where 0.8 is the amount of transparency:

    #top.post-type-archive-product .content .box {
    background-color: rgba(255, 255, 255, 0.8);
    }

    The theme does make multiple copies of images for various uses. On the single product pages however it is using the image size set for ‘blog’ in the functions.php in your theme files. This has a set width of 430px but is being stretched to 660px on the single product page causing it to look a bit blurred. You can change the width in that functions.php and then use a plugin to regenerate your thumbnail images based on the new size.

    http://wordpress.org/extend/plugins/regenerate-thumbnails/

    You can see your posts here: http://www.kriesi.at/support/profile/balero98

    I’ll tag the topic for Kriesi and another of the Support crew re: the sidebar not hiding

    Regards,

    Devin

    #79728

    Thanks for the response, Devin. Hiding the buttons and making the product thumbs the link worked like a charm. Thanks.

    I added the CSS for the transparent background for product and shop pages to my custom.css file, but no dice. Any idea why?

    #79729

    It may need to be adjusted for the product pages that are using shortcodes and then for individual product pages as well. So:

    #top.woocommerce-page .content .box {
    background-color: rgba(255, 255, 255, 0.8);
    }

    and

    #top.single-product .content .box {
    background-color: rgba(255, 255, 255, 0.8);
    }

    #79730

    Hey! The sidebar is not hiding because in your custom.css you have added a rule that sets the left property of the sidebar and also added the !important parameter. Important disables animation via javascript since it basically tells the browser to ignore other style settings and use only this one.


    #top .sidebar2 {
    left: 992px !important;
    padding: 0;
    top: 49px;
    z-index: 1;
    }

    would recommend to remove this line and replace it with:



    #top .sidebar2 {
    margin-left: 230px;
    padding: 0;
    top: 49px;
    z-index: 1;

    #79731

    Thanks Devin. Worked like a charm.

    Really needing help with the right sidebar not hiding with the rest of the content. Haven’t found anything on this int eh forums. Any ideas?

    Thanks!

    #79732

    Hi!

    read the message above pls :) We probably posted simultaneously :D

    Regards,

    Kriesi

    #79733

    Thanks Kriesi! That did the trick.

    #79734

    Glad its working for you now :)

    Set to resolved.

    Regards,

    Devin

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘A few Flashlight questions.’ is closed to new replies.