Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #219503

    Hi, could you help me?
    I have a problem to set opacity:1; on the active link (the link of the current page), i’ll explain better :

    1) this is my url site : http://www.hattusas.it
    2) I set “css classes (optional)” for every item of the menu (ex: “item_home” for the home link)
    3) I uploaded an icon in the media library for every item of the menu
    3) I changed “custom.css” adding : this code for every link of the menu

    .item_home {
    background: url(http://www.hattusas.it/wp-content/uploads/2014/02/home_icon.png) no-repeat center; 
    text-align: center;
    width: 60px;
    opacity: 0.4;
    }
    
    .item_home:hover {
    opacity:1;
    }

    that work very well but i’m not able to set the opacity:1 for the active page.
    I tried using this code and similar in the custom css :

    .current-menu-item > a {
    opacity:1 !important;
    }

    but doesn’t work, could you help me?
    thank you! :)

    #219701

    Hey Susanne!

    Please add following code to Quick CSS in Enfold theme options under Styling tab

    li.current-menu-item {
    opacity: 1;
    }

    P.S.: Nice website!

    Regards,
    Yigit

    #219967

    Thank you!
    It works perfectly! :)

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Active links on main menu’ is closed to new replies.