Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #19950

    Hello,

    Problem … I have set 4 meta fields in portfolio option -> ‘Add new portfolio meta fields’. Let’s say at position 1 ‘First Name’, at position 2 ‘Last Name’, 3. Gender and 4. Age

    A while ago I added new meta field at position 3 ‘City’ and all of my fields are moved in position -1, so the data I added before to 3. Gender are now under ‘City’ , ‘Age’ data is moved to ‘Gender’ as Gender is now at position 4. and so on.

    This is a big problem when you have a lot of portfolio posts. We probably need some unique ID for meta fields so they are not messed when you reorder meta fields or add new field in position between old meta fields.

    This is somehow urgent to me before I start to add items to portfolio, or at least let me know how quickly or if it can be fixed ( Don’t like to use plugins when we have this option in theme, I’m thinking to switch to Custom Fields Suite plugin)

    The same question 8 months ago: http://www.kriesi.at/support/topic/portfolio-meta-information-bug

    Thanks

    #105701

    Hi,

    Kriesi just saves the meta field keys into an array and you can’t reorder them without breaking the meta values. Tbh I don’t expect an update in the near future because the option panel does not support “reordering” atm and it would require some framework changes. The only workaround/hack I can offer is that you overwrite the $p_meta array with your custom order manually. Open up functions-replete.php and replace:

    $counter = 0;
    foreach($portfolio_keys as $key)

    with:

    $temp_sort_arr = array();
    $temp_sort_arr = array(
    $p_metas[0],
    $p_metas[2],
    $p_metas[1]
    );

    $p_metas = $temp_sort_arr;
    $counter = 0;
    foreach($portfolio_keys as $key)

    and instead of the sample order use your order 0 is the first item, 2 the last.

    #105702

    Hi,

    I have a problem my site. The portfolio page.

    http://turkalinka.com/?page_id=38

    If you are click to “Folklor Kıyafeti” or other categories, and go to under the footer. Why? Help me please.

    #105703

    And look at the right navigation bar, there are two bar.

    #105704

    Hi cemilturken,

    The plugin Mini 360 Viewer is causing constant errors and seems to be causing the big footer issue. Disabling that plugin should fix the issue.

    Regards,

    Devin

    #105705

    Hi Devin,

    I’m using LayerSlider WP, Dynamic to top, Uber Menu, Wysija Newsletters, WPW – 360 Viewer, and WordPress FlippingBook plugins. I Disabled all plugins. And I tried again. But, unfortunately, not solution.

    #105706

    You get the same error with all plugins disabled?

    Can you try disabling them all then viewing the site on another computer or when you view the site (with all plugins disabled) try refreshing it 3-5 times to make sure all local cache is cleared.

    #105707

    I’ll try your suggestion.

    I opened at Chrome and Firefox, takes issue. But, no problem IE.

    #105708

    I suspect there is a conflict with one of the plugins and how the content should be output. For whatever reason IE isn’t rendering the issue the same but the others are.

    Regards,

    Devin

    #105709

    Ok Devin,

    Thank you so much.

    Regards.

    Cemil

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Add new portfolio meta fields Bug’ is closed to new replies.