Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15785

    Any idea why my Add to Cart button is not lining up underneath the picture on the individual product pages?

    http://rattlethebox.com/shop/pottery-painting-at-2000%CB%9A-degrees-copy/

    I also lost my footer somehow for those pages? Any idea?

    #88996

    Hi,

    You have 8 javascript errors on the page:

    Unsafe JavaScript attempt to access frame with URL http://rattlethebox.com/shop/pottery-painting-at-2000%CB%9A-degrees-copy/ from frame with URL http://www.youtube.com/embed/KPOtSCMli7Q?fs=1&feature=oembed. Domains, protocols and ports must match.

    Unsafe JavaScript attempt to access frame with URL http://rattlethebox.com/shop/pottery-painting-at-2000%CB%9A-degrees-copy/ from frame with URL http://youtube.com/embed/1dwMTmpz05U. Domains, protocols and ports must match.

    Uncaught TypeError: 0 is not a function jquery.js:2

    Unsafe JavaScript attempt to access frame with URL http://rattlethebox.com/shop/pottery-painting-at-2000%CB%9A-degrees-copy/ from frame with URL http://www.youtube.com/embed/KPOtSCMli7Q?fs=1&feature=oembed&wmode=opaque. Domains, protocols and ports must match.

    GET http://i2.ytimg.com/vi/1dwMTmpz05U/hqdefault.jpg 404 (Not Found) i2.ytimg.com/vi/1dwMTmpz05U/hqdefault.jpg:1

    Uncaught TypeError: Object #<HTMLUListElement> has no method 'splice' ajax_layered_nav.js:209

    Uncaught TypeError: 0 is not a function jquery.js:2

    Uncaught TypeError: Object #<HTMLLIElement> has no method 'splice' ajax_layered_nav.js:209

    You are running two javascript frameworks – jQuery and Mootools in multiple plugins on the same page. Are you sure everything is in compatibility mode and in no conflict? jQuery adds internal identifiers to everything it touches and then Moo starts cloning those identifiers and pulling at innerHtml, and all of a sudden the shopping cart pops up in the header.

    I am sure if you took whatever is causing the errors off (plugin) everything will return to normal.

    Thanks,

    Nick

    #88997

    Thanks Nick, I appreciate your help as this is a bit outside my comfort zone. I disabled every one of our plugins and it still has the same error. I also added this code into our functions.php file (http://wcdocs.woothemes.com/snippets/automatically-add-product-to-cart-on-visit/) but then took it back out to see if that was causing the error – but nothing changed there either. Any other ideas on how to troubleshoot it?

    Spud

    #88998

    Hey Spud,

    First I would try updating your theme files. There have been quite a few bug fixes since 1.3.2 and some big compatibility changes to work with the newer versions of WooCommerce. My guess its just a change in woocommerce 1.6 vs the older theme files and how it spits out the layout :)

    Regards,

    Devin

    #88999

    Awesome – thanks everyone – we got it fixing after updating some of the files to newer ones!

    Spud

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Add to Cart button not formatted’ is closed to new replies.