Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7689

    Is it possible to add some code (javascript to be specific) to an Aviaslider slide in the corona theme, to embed a video in that slide? I understand that I could host them on Youtube, or Vimeo etc. but I want to get an external player I’m using in there if I can. The videos are hosted on Amazon S3 and I’ve tried using the direct URL for them in the “Add video from URL” page however the video will not play (they’re in MP4 format, h.264).

    Is this an unattainable goal or can I get there somehow? I thought of hard coding the slider into one of the pages but I’m not sure where to begin with trying to do that. Any help would be greatly appreciated!

    #58937

    We use this player: http://www.projekktor.com to embed self hosted mp4, flv videos, etc. They should appear in the slideshow area too. However I’m not sure if it works with amazon S3 or if you need to upload the video locally. Did you try to stream local videos?

    #58938

    I’ve tried streaming local videos and it gives me the same result. The default player loads but it endlessly buffers and doesn’t play the video. It also isn’t displaying correctly in the slider, the player seems to stretch on behind the other slides instead of staying inside the visible slide area in aviacordion.

    #58939

    Not sure whether I should make a new topic for this or not as it’s unrelated but I don’t want to clutter up the place. I’ve just noticed the theme is misaligned when using the boxed layout (and still is with the stretched, however it is not as noticeable), specifically, at the top of the page (no matter what layout options I select) the content area below the header is bigger, coming out past the right hand side of the header (example here: http://dl.dropbox.com/u/4379134/Pictures/corona%20header.jpg). This also occurs at the bottom of the page, with the sizes decreasing from the content area to the footer to the bar at the bottom of the page, all out of alignment (example: http://dl.dropbox.com/u/4379134/Pictures/corona%20footer.jpg). Nothing I seem to do fixes this, I had thought it was because my logo was too big but switching back to the default corona logo brings no improvement, and I haven’t edited any of the theme files.

    EDIT: Nevermind, I see that someone had already posted about this and a temporary solution given, sorry about that! :)

    #58940

    Pictures do work you just need to remove the “)” from the end as this forum has seen fit to include that in the link for some reason.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Adding code to an Aviaslider slide’ is closed to new replies.