Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #20172

    Hi Guys,

    Sorry, this topic has been talked a lot I guess at least from what I”m seeing. I tried a couple of solutions you mentioned in other topics, like this one changing the end of the head and adding the bellow to the style.css file.

    .language-select {

    position: absolute;

    top: 0;

    right: 0;

    }

    If you check the site: http://iconkyanigroup.com/ you will see the icons standing around the bottom left end of the slider wow.

    Let me know how to fix it and put them up there next to the social icons please ?

    Thanks in advance,

    Dobromir

    #106558

    Try to replace following code in the html source code:

    <div class="language-select">

    with:

    <div class="language-select avia_wpml_language_switch">

    The reason is that our themes work with the WPML translation plugin and Kriesi included some preset styles for the language switcher.

    #106559

    Hi,

    Thanks for the info. Actually I was looking into WPML and it was something with too many functions that’s why I was thinking to have in sub-domains and just redirect it.

    I guess now will need to do it with WPML.

    Thanks,

    Dobromir

    #106560

    Hey!

    Actually if you just want to position the flags properly you just need to replace the code I posted above :)

    Regards,

    Peter

    #106561

    Hi Peter,

    Hmm.. things got tricky. I decided to buy and use WPML and actually its not that bad, I like it. It seems working perfectly.

    Now I probably tried everything found in other topics but they are mostly for Avisio theme and doesn’t seem to be working any of those. So I’m back to Step 1.

    At the end the idea is to have WPML language display to show before the phone and the social icon at the top.

    I have checked and within Corona there are no head id’s or h2 classes so I guess the solution should be something different.

    Can you have a look when you have a minute ?

    Thanks,

    Dobromir

    #106562

    Try following – open up header.php and replace:

    do_action('avia_add_social_icon','header');

    with:

    do_action('avia_add_social_icon','header');
    do_action('avia_meta_header');

    This code change should activate the icons.

    #106563

    Hi Man,

    Thanks it worked until some point. Something appear nex to the social icons but there are just those “/” lines without the flags or language name.

    Please have a look at the site. I will keep it that way so you can review it.

    Thanks,

    Dobromir

    #106564

    Hey!

    Add following code to css/custom.css to fix the issue:

    .avia_wpml_language_switch li .language_flag img{
    display: block !important;
    }

    Best regards,

    Peter

    #106565

    Hi Peter,

    Perfect, thanks a lot! All sparky :)

    Cheers,

    Dobromir

    #106566

    Hi,

    Glad that Peter got you back on track.

    Good Luck,

    Nick

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Adding language flag next to the social icons’ is closed to new replies.