Tagged: ,

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #255556

    Hi

    I have updated to 2.7 and WP 3.9 and now getting the following JavaScript error from Chrome whenever I try to edit a page:

    ReferenceError: Â is not defined
    
    http://boadev.co.uk/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/js/avia-builder.js?ver=0.7:394&host=boadev.co.uk

    site is: http://boadev.co.uk/

    Any advice greatly appreciated, the site is due to get transferred to its live domain tomorrow! Thanks

    #255656

    We are unable to edit our site due to this error, can any one advise please?

    #255659

    Hey!

    Please try re-updating the theme via FTP – http://vimeo.com/67209750

    Best regards,
    Yigit

    #255859

    Hi Yigit

    I’ve re-uploaded enfold 2.7, flushed all caches and flushed the permalink structure but still getting the error?

    #255965

    This site is due to go live today and we are still unable to edit pages due to this error. Can anyone please advise on a solution?

    Thanks

    #255969

    Hey!

    Please create us a ftp and wordpress admin account and post the login credentials as private reply.

    Best regards,
    Peter

    #255979
    This reply has been marked as private.
    #255987

    Hey!

    Did you try to deactivate all plugins. I couldn’t reproduce the issue you mentioned in your first post (in fact I can edit the page content with and without the Advanced Layout Builder just fine) but i.e. the Ultimate TinyMCE plugin triggered several errors. Also the plugin author: http://wordpress.org/plugins/ultimate-tinymce/ warns about the WP3.9 compatibility.

    Best regards,
    Peter

    #256000

    Hi Peter

    I should have caught that Ultimate tinyMCE issue! I’ve now removed the plugin but still having problems.

    It appears to be with any element that has the MCE editor. When I edit the homepage for instance I can move things around without a problem but if I open the testimonials and edit the content for example, when I update the page a lot of the content is deleted and the layout is changed. I have to revert back to the auto-saved page.

    I have copied the content from the homepage to a test page: http://boadev.co.uk/test-page/ if you edit the contents in the testimonials and update the page you will see the issues.

    Thanks
    Dan

    #256001

    I have also tried deactivating all plugins.

    #256034

    The site currently has no plugins other than PODs for our CPT’s and Gravity Forms activated, when trying to make changes to the test page as above we are getting the JS error.

    #256057

    I down graded the site back to 2.6.3 (didn’t have a 2.6.4) and still received the following JS error:

    ReferenceError: Â is not defined
    
    http://boadev.co.uk/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/js/avia-builder.js?ver=0.7:394&host=boadev.co.uk

    I downloaded a fresh copy of 2.7 and now reinstalled this and still the error?

    #256176

    Can anyone provide any support with this issue? The site was due to be transferred to the live domain today and this now can not happen due to this problem.

    #256319

    Hi!

    I tried to reproduce the issue in the test page, here’s the result:

    http://screencast.com/t/4GPtFRJk5qM4

    Best regards,
    Josue

    #257038

    Hi Josue

    This is what I’m getting:

    http://www.screencast.com/t/cHijPsP1a3sp

    Could this problem have anything to do with this issue: http://wordpress.org/support/topic/jquery-ui-dialog-script-moved-out-of-39-latest-build

    Thanks
    Dan

    #257409

    Hey!

    I see, definitely that “” should not be there, try restoring /config-templatebuilder/avia-template-builder/assets/js/avia-builder.js file via FTP, here’s the file.

    I tried doing it with the FTP access you posted but it returned a white screen when i accessed it.

    Cheers!
    Josue

    #257507

    Hi Josue

    I have already restored all files from a fresh download and even tried down grading but the issue is still there. I will try the file you have provided however.

    That “” only appears on line 336 when something is dragged and dropped, prior to dropping the item it is not there?

    This site was due to be moved to the live domain 5 days ago and printed media about the site is in production and due for distribution in 4 days so I’m really up against it. I’d really appreciate it if we can get this resolved. Do you offer any higher levels of support with faster response times?

    Thanks
    Dan

    #257528

    Hi

    I have updated the avia-builder.js as suggested but still not resolved.

    I’ve found this thread: https://github.com/jquery/jquery-mobile/issues/4540 could this be related?

    #257534

    Hi!

    This thread https://github.com/jquery/jquery-mobile/issues/4540 might be the solution:

    This is typical of UTF-8 misinterpreted as ISO-8859-1 (latin1)

    Did you check the “character encoding” setting of your browser? Make sure it’s set to UTF-8. Go to the admin page, then check the character encoding and set it to UTF-8. Afterwards clear the cache and reload the admin page.

    https://support.google.com/news/answer/61689?hl=en-GB

    Cheers!
    Peter

    #257542

    We appear to be getting somewhere! http://www.screencast.com/t/r4DXSlI8e

    Is this an issue within the theme? When I changed the settings in the browser (chrome) back to UTF-8 for the admin screen I’m able to make changes without the JS error appearing.

    #257573

    I have the problem resolved! Simply adding UTF-8 back into the Blog Charset field in the site settings has the site working correctly again.

    Thanks for you help guys, please mark this as resolved.

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘After 2.7 and 3.9 updates getting JS errors’ is closed to new replies.