Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #26461

    I’m using WPML plugin for a multilingual website, and after I upgraded the theme to version 1.8.1 all my pages return a 404 Error. I’ve already try to remove the permalink and save it again, but is not working. Only works if I put as Default.

    What was changed it in order this problem appeared?

    Even returning to version 1.7.1, the problem persist.

    #130491

    Any help, please?

    #130492

    Ok, I discover how to reproduce the error. Everytime I change anything in the option panel from the theme, I have to deactivate WPML Plugin, save permalinks, and activate again.

    I cannot give any url because I’m working on localhost, but I create a demo page in a server, and happens the same thing.

    #130493

    Try to install http://wordpress.org/plugins/rewrite-rules-inspector/ and check if any rewrite rules are marked as “missing”. You can also use the button “Flush Rules” to rewrite the rules/htaccess file if necessary. If this doesn’t help try to install the latest beta version of WPML (running on my test server at the moment).

    #130494

    Thanks for the answer. Now pages are redirect correctly, but the categories still with 404 Error. I’m really frustrated with this. I’ve already reflush the permalinks, and the only way that everything works is with the Default option of permalinks configuration, and for SEO-Friendly is unacceptable.

    Thank you.

    #130495

    Hi!

    Please create me a wordpress admin account and send me the login data and more details about the issue to: (Email address hidden if logged out)

    Best regards,

    Peter

    #130496

    Don’t worry, I’ve already figured out the problem. I add flush_rewrite_rules(false); after de register for the taxonomy for the portfolio and everything works fine again.

    #130497

    Hi!

    Great – glad you found a solution :)

    Regards,

    Peter

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘After the upgrade pages return 404 Error’ is closed to new replies.