Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #20493

    Hi,

    I am using the portfolio option as a “featured” page (http://pocketfullofapps.com/featured) on my website to display the top X amount of articles for a given amount of time. When I go to add a portfolio with a featured image and publish it, some images do not display evenly as shown currently. To explain further, I want all images on the front of the portfolio page to display as normal like the “Auxo” and “Facetime” pictures; NOT like the Camera Genius or Timbre pictures. How do I correct this? Thanks! :)

    #107865

    Hi,

    Please try to add this on your custom.css

    .page-id-55566 #top .slideshow li img {
    max-height: 220px!important;
    }

    Reload the page.

    Regards,

    Ismael

    #107866

    I just tried and it changed nothing. I cleared my cache as well…

    #107867

    I played around with the css code you offered, the page ID is correct. I opened up FireFox’s inspect element and I think it’s something other than .slideshow li… Not sure though. :/ Thanks for all the help thus far.

    #107868

    Also, how do I get it to sort by date? (newest being displayed first, oldest being displayed last). Much thanks! :)

    #107869

    Anybody?

    #107870

    1) Use following code instead:

    #top.page-id-55566 .slideshow li img {
    max-height: 220px!important;
    }

    2) You want to change the image order? If yes, open up wp-contentthemesangularincludeshelper-slideshow.php and replace following line:

    $this->slides 			= avia_post_meta($this->post_id, 'slideshow');

    with:

    $this->slides 			= avia_post_meta($this->post_id, 'slideshow');
    $this->slides = array_reverse($this->slides);

    #107871

    The CSS trick worked, many thanks! :)

    As for the order, I get an error. I can add a screenshot if needed.

    #107872

    Hi Aaron,

    Make sure you put in the change exactly as Peter has it above. I just tried it on my live install without any issues.

    Regards,

    Devin

    #107873

    This is the error I get: http://imgur.com/rEAp3sd

    Is the variable not called or something? Thanks again for all the help.

    #107874

    Also, I have pagination enabled. When I go to http://pocketfullofapps.com/featured/page/2 it redirects me to the home page. Any help there? Thanks! :)

    #107875

    Please try to replace:

    $this->slides 			= avia_post_meta($this->post_id, 'slideshow');
    $this->slides = array_reverse($this->slides);

    with:

    $this->slides 			= avia_post_meta($this->post_id, 'slideshow');
    if(is_array($this->slides)) $this->slides = array_reverse($this->slides);

    #107876

    Hey Dude,

    Tried the code it didn’t change anything. :/ It’s alright, I’ll just leave it as is. Any word on the pagination?

    #107877

    Hi Aaron,

    What do you have for the setting in your Theme Settings>Portfolio for “Enter a page slug that should be used for your portfolio single items” ? The slug here should not be the same as any page name, post name or category name anywhere else on the site. If for instance it is featured, having the page and category name of featured would cause these kinds of issues as the slugs have to be unique to allow wordpress to properly navigate between them and display properly.

    Regards,

    Devin

    #107878

    Tried that and it worked, thanks Devin!

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Angular and Portfolio Image Display Problems’ is closed to new replies.