If you have troubles since the update to WordPress 4.5 please read this post before opening a new thread.

Tagged: ,

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #11873

    Hi,

    We’ve purchased the Angular theme, and the shortcodes work if manually typed into the editor. However, when using the magic wand tool, only the basic ones like horizontal rule can be inserted. Any shortcodes that bring up the overlay result in a white, blank page (screenshot). This makes the theme unusable for the client editors.

    There are several threads across different themes with the same or similar issues:

    We’ve tried pretty much all the suggestions, as well as the basic troubleshooting things you’d expect. These include:

    • Disabling all plugins (there actually aren’t any yet – it’s a fresh install)
    • Making sure WordPress and plugins are up to date
    • Reinstalling the theme
    • Uploading the compressed theme to the server and extracting it there
    • Disabling mod_security
    • Checking for appropriate file and directory permissions
    • Discussing the issue with the hosting company: they can’t find anything wrong on their end that would cause this, and they’re actually really helpful when it comes to support
    • re-upload the framework>php>avia_shortcodes folder (as suggested by Devin)

    So we’ve tried everything we can think of, and it’s not working. It’s critical that this work, so does anyone have a solution?

    Thanks!

    #73421

    Hi AllysonA,

    Thank you for the detailed message! Could you tell us what browser/version you’re using? For example, I’m using Firefox 11.0 and on my install of Angular all the shortcodes work.

    In the meantime, I’m going to forward this to the rest of the support team as well as Kriesi to see if they may have a resolution for you.

    Regards,

    Mya

    #73422

    Thanks Mya for the quick response!

    I’m on a Mac, using mainly Firefox 12. But I’ve also tried with Safari (5) and Chrome (18) – behavior is the same on all three browsers.

    #73423

    Hey AllysonA,

    This has been popping up here and there recently but I still have not been able to find a continual root cause. If you are by chance with HostGator, did you try the suggestion of contacting them re: Timthumb?

    Regards,

    Devin

    #73424

    Hey Devin,

    This is not with Hostgator, but I did contact the host and point them to the post about Timthumb – that’s not the issue here.

    mod_security was enabled by default, so I thought I had found the issue there, but I disabled it through .htaccess and it didn’t make a difference. I asked the host to double check that mod_security was indeed disabled effectively, and they confirmed it was. So I’m still stumped/frustrated.

    Thanks.

    #73425

    Its a frustrating issue because it isn’t widespread and I still don’t see any common denominator. Could you possibly post your hosting specs here?

    #73426

    Sure, what specs do you want to see?

    #73427

    Memory, OS(32bit or 64bit), PHP version. If its on something like a dedicated virtual plan server or a generic hosting plan. The more the better at this point :)

    #73428

    Hi Devin,

    It’s a pretty standard shared hosting setup. Linux i686, PHP 5.3.8, Apache 1.3.42, etc. The results of phpinfo() are below, with a few values removed for privacy/security. Let me know if you need any other details.

    Thanks!

    EDITED INFO too long, use pastebin.

    #73429

    Thanks AllysonA.

    We’ll update as soon as we have something :)

    #73430

    Hi, I found a solution.

    You have to modify:

    propulsionframeworkphpavia_shortcodestinymcedialog.php

    and

    propulsionframeworkphpavia_shortcodespreview-shortcode-external.php

    search for following line to find the right code:

    Code:
    foreach ($paths as $path)
    {
    if(@include_once($path.’/wp-load.php’)) break;
    }

    replace with:

    Code:
    foreach ($paths as $path)
    {
    if(@file_exists($path.’/wp-load.php’)) {
    include($path.’/wp-load.php’);
    break;
    }
    }

    Thats works for me.

    Regards,

    Ivan

    #73431

    Ivan, that works! Thank you so much!

    Devin, Kresi, et al – now that I’ve changed files in the angular theme folder, my changes will get overwritten by the next theme update, correct? If so, can you incorporate this change into the themes, or let me know of a way to ensure the changes don’t get overwritten?

    #73432

    You are correct AllysonA. You could manually update the theme files based on the changelog if need be. I would suggest though you make a backup of the two files just in case. As far as incorporating the change that Kriesi’s decision. We’ve flagged him on this thread.

    Regards,

    Mya

    #73433

    OK, thanks. Marking this thread as solved.

    Ivan, thanks again!

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Angular: Insert shortcode with magic wand – popup overlay is blank’ is closed to new replies.