Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #283701

    I can only have a maximum of 48 images in the “Featured Media” section of a single portfolio entry. Am I doing something wrong, since it says “add any number of images and/or videos”?

    When I add the 49th image, it shows up in the list underneath the 48th image, but when I “update” the page, it goes away.

    Example:

    http://visualimpactsystems.com/trade-show-graphics-examples/

    (click on “Banner Stand Graphics”)

    Running WordPress 3.9 and Angular 1.5

    [ Note: Comfortable with changing the PHP code, if need be ].

    Thank you, ahead of time, for your efforts.

    Mark Besh
    Visual Impact Systems

    #283781

    Hi mbesh!

    Please firstly update Angular theme to the latest version 1.8 via FTP – http://vimeo.com/67209750

    Cheers!
    Yigit

    #284140

    Yigit,

    If possible, we would rather not upgrade right now—we have changed A LOT of code, and just don’t have the time right now to do it all.

    Is it possible to change a ‘bit’ of code to allow us to have more than 48 items in a single portfolio entry?

    Thanks,
    Mark Besh
    Visual Impact Systems

    #284644

    Hi!

    Please try to increase the allocated memory to 128M: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Regards,
    Yigit

    #387411

    Yigit,

    We upgraded to Angular 2.0 and increased the allocated memory to 128M, and we still cannot add more than 48 images to this one portfolio.

    Any ideas?

    Mark Besh
    Visual Impact Systems

    #388947

    Hi!

    Can you still add images on any portfolio items with less than 48 images? I don’t know of any limitation on the slider images.

    Best regards,
    Ismael

    #390283

    Ismael,

    Yes, we can add images to portfolios that have less than 48 images. (Added a few to “Podium Graphics”).

    http://visualimpactsystems.com/trade-show-graphics-examples/

    Just to test this, we had a portfolio with 46 images in it (“Pop-up graphics”), and added the 47th successfully, and added the 48th successfully, but the 49th could not be added.

    [ FYI: “Banner Stand Graphics” is the other one with 48 images ].

    Mark

    #390739

    Hi!

    Thank you for the info. Please post the login details here including FTP access. I’ll ask Kriesi to take a look.

    Best regards,
    Ismael

    #390765
    This reply has been marked as private.
    #391398

    Hey!

    It doesn’t matter which email. Post the login details here as a private reply so that every moderator can see it.

    Cheers!
    Ismael

    #391585
    This reply has been marked as private.
    #393746

    Moderators,

    Any thoughts on how to put more than 48 images into a portfolio?

    Thanks for your efforts,
    Mark Besh

    #394781

    Hey!

    Is it ok if we upload a fresh copy of Angular on your staging site? You mentioned that you did quite a few customizations so it could very well be one of them that is causing the problem.

    Best regards,
    Elliott

    #397126

    Elliott,

    We deleted the ‘old’ Angular folder and then copied a ‘fresh’ copy of Angular 2.0 into the themes folder. Then we tried to add the 49th image to the “Banner Stand Graphics” portfolio. The check mark appeared to tell me it was added (and I could see that it was added in the background behind the add image ‘dialog box’), but when I updated (saved) the page, it ‘discarded’ the addition, and would only show 48 images.

    Hmmmm…

    Mark

    #398433

    Hi!

    Since we did not code any limits into the theme my best guess is that there is a problem with the server settings. One thing that comes to mind is that adding that many images and saving the page will send a lot of input fields to the server. Servers usually got a limit of input fields they accept.

    You can try to increase that limit by opening the .htaccess file in your wordpress root folder and add this line at the top:

    php_value max_input_vars 5000
    

    let me know if that helps
    Cheers!

    Kriesi

    #398469

    Kriesi,

    We did do this, and it did allow us to add 3 more images, but it seem to slow the interactivity down, and it gave us a “WordPress Failure Notice” (Timeout) after updating the page to save the additional images to the portfolio (this has never happened before, even when we’ve been editing for hours).

    This is the .htaccess:

    php_value max_input_vars 5000

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    ==========

    FYI: We use “WPEngine” for our hosting (purported to be one of the fastest WordPress hosting platforms in the world – http://wpengine.com/ ).

    Do you think that they don’t ‘like’ the increase, or maybe it should be another value or done a different way by them?

    Mark

    #398474

    Hey!

    Truth to be told, I cant imagine why this would cause such a timeout. The only thing that rule does is allow up to 5000 $_Post Parameters. you might actually be happy with

    php_value max_input_vars 2000
    

    as well. If using this causes problem with wpengine I would recommend to ask their support team if there is something that can be done to fix this, I hear they are very helpful :)

    #400962

    Kriesi/All,

    That DID IT! We’ve been able to add up to 6 more items (what we needed right now) to a few portfolios than the previous max of 48. [ FYI: WPEngine said that their maximum is 2000 ].

    We VERY MUCH appreciate all the efforts everyone put into this!

    ISSUE CLOSED.

    Mark Besh
    Visual Impact Systems

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘Angular – Portfolio Entry, Featured Media, Maximum Number of Images (48?)’ is closed to new replies.