Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #179264

    Hi, two questions about the portfolio animations:

    1. I have set up my site to show a portfolio on the home page like on your demo home page. Something happens both on your demo, and it seems to a worse degree on my site – the individual portfolio images load, as a user you see this, and then they reload again in an animation that sends them out across the page from the left top corner of the portfolio div. I really don’t like that double loading. Is there a way to dismantle the animation that sends them out from the left corner? So that the images just load, and that’s it?

    2. I also don’t like when you click on an individual portfolio item that circle animation that starts as a spot on the page and then grows bigger to reveal the portfolio item as if you are flying through a keyhole. I’d like to disable that animation too. But I like everything else.

    Please advise if I can disable these two animations, but keep everything else about how the portfolios load and display.

    thanks,

    j

    #179282

    Hi,

    Can you post the link to your website please?

    Regards,
    Josue

    #179341
    This reply has been marked as private.
    #179351

    Hey!

    Open this file http://acmedia.wpengine.com/wp-content/themes/eunoia/js/avia.js, replace the following:

    Line 578:
    overlay.animate({opacity:0}, 800, function()

    By this:
    overlay.animate({opacity:1}, 800, function()

    Line 637:
    methods.animation_support();

    By this:
    //methods.animation_support();

    Best regards,
    Josue

    #180130

    Hi Josue,

    Thank you, this is exactly what I want!

    I appreciate your prompt support too!

    Best,

    James

    #180138

    Hi Josue,

    Perhaps I spoke to soon! I noticed that on ‘first load’ of the website, your code changes stop the animation. But, if I re-load the home page, the animation reappears. : (

    Any further advice to have the animation stopped on all loads?

    Thanks,

    James

    #180140

    Glad we could help James. Let us know if you have any other questions or issues :)

    Regards,
    Josue

    #180142

    Hey!

    I performed some tests here, working as expected, have you tried flushing your cache?

    Best regards,
    Josue

    #180781
    This reply has been marked as private.
    #180804

    Hi James!

    Yes, i tested it on Firefox 23 (Mac OS X). the script is working as expected, have you tried it from another computer?

    Best regards,
    Josue

    #180811

    Hi Josue,

    Yes, I just tested it on two other computers, a laptop and another desktop, both Macs running Firefox v.24.

    Same problem – in Firefox, the animation restarts on second reload (or, for example, if I click the ‘portfolio’ link which contains the animation too).

    In both other computers the behavior does not happen in Safari or Chrome.

    So it does seem to be Firefox specific, and maybe specific to v.24. I don’t have an earlier version of Firefox installed so I can’t test that.

    On one of the computers I just tested, the site had never ever been loaded in Firefox, so definitely not a cache issue there either.

    j

    #181140

    Hey!

    I’m sorry but i’m unable to reproduce it, here is how it works for me (FF 24):

    http://screencast.com/t/On4B6XxrSB

    Cheers!
    Josue

    #181156
    This reply has been marked as private.
    #182117

    Hey!

    This is actually the default and as far as I know correct way for the page to load. The items load in individually and then when the script is done it re-sets everything to be positioned correctly.

    Cheers!
    Devin

    #182217
    This reply has been marked as private.
    #182259

    Hi!

    The changes i suggested were to disable the opening/closing animation of the portfolio items, regarding the load issue, it would need another modification i think

    Cheers,
    Josue

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Animation Loading’ is closed to new replies.