Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #19402

    Hi there,

    I have another bug in the masonry gallery which also appears on this page: http://www.kriesi.at/themes/flashlight/portfolio-item/masonry-portfolio-example-flexible/

    When I click on a thumbnail while more images are loading, the picture opens, closes again and then the whole page is behind the transparent lightbox background and nothing is working anymore.

    Can you please make a fix on that issue?

    Here is my page

    http://www.phamousphotography.de/ (on the people site its easy to get the same bug because of its many images)

    Thanks,

    Joe

    #103571

    Hey Joe,

    The bug has been reported in the past but I’m not sure there is a fix available for the lazy loader script at this time. I’ll tag this post for Kriesi so that he’ll see the issue and can address it.

    Regards,

    Devin

    #103572

    yes, we already fixed that one before. problem is that the masonry script creates a racing condition which is unable for us to fix. most of the time when a user clicks on an image while loading more the lightbox will close correctly but based on the loading execution there are moments when the script tries to close the lightbox and it then opens. this is when the error occurs.

    I have tweaked the script a little more now to prevent this but I am afraid, as long as the infinitescroll script doesnt get a better API I will not be able to fix that 100%

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Anothe Bug in the Masonry Gallery’ is closed to new replies.