Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #3338

    Are there any new updates to when an update will be available to fix the 3.1 problems?


    We’ll release an update notice. It’s ready soon but Kriesi wanted to make sure that all bugs will be adressed by the updates (not only W3.1 bugs) and delayed the release a bit.


    sounds good, thank you!



    Updates were released last night and should be available from your Downloads page on Theme Forest.



    Hi there

    I’m still having issues despite having updated the files as outlined in the version.rtf file. On – you’ll see that if you go via the main nav FIND A HIKE, and then try to click on portfolio items, it generates a 404 error.

    Instead of the links being this:

    They are like this:

    Any idea what I can do to fix this? Was working before the update to 3.1.




    Kriesi forgot to mention two files to update (in version.rtf):

    kclass_advanced_css_style.php located in framework/classes/ and portfolio.php in theme_options folder. Please update them too. Then try to reset your permalinks? Go to Settings > Permalinks and click on the “Save” button.



    Yes, I saw that post about the extra two files, and had updated those as well. I’ve just tried re-setting the permalinks but that doesn’t seem to work either. It’s still not generating the correct link to the individual portfolio items… I also checked that there are no doubles of category names – there is no ‘portfolio’ category under normal posts that might clash with the Habitat portfolio setup.

    For whatever reason, it’s now generating links like this: /portfolio/lions-head/

    Instead of this: /?portfolio=lions-head

    Any ideas?



    Mmmm…. ?portfolio=lions-head is the standard permalink structure (which is used if you don’t set a custom permalink structure under Settings > Permalink). If you set the permalinks to “default” you’ll get /?portfolio=lions-head

    If you use i.e. /%category%/%postname% you’ll get /portfolio/lions-head/


    Yes, I manually created those links with ?portfolio=lions-head myself before I’d fiddled with the permalink structure. It was the other links that weren’t working when WP was updated to 3.1. Anyway, it seems to have resolved itself so can only assume that despite clearing cache I was still seeing an old version without the latest updates – and now the /portfolio/lions-head/ link (et al) is working fine. Thanks for your patience and help!


    Glad that the permalinks work now :)

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Any new updates on the 3.1 problems?’ is closed to new replies.