Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13926

    When I add an image gallery to an article, the article image displays twice within the gallery lightbox. When the image is removed from the gallery section, the article image is removed as well. Is there any workaround to this problem?

    Is it also possible to show all gallery images only in the lightbox which is evoked from the article image? In that case only the article image is shown at the beginning of the article and all other gallery images would not been shown at all.

    thanks

    #81285

    Hi atfachverlag,

    I believe the lightbox takes its gallery in the pop up from all the images present on the page but I don’t think there is a way to add in a full gallery only in the pop up if the images are not on the page.

    As for the main issue, can you link to your site so we can take a look at what might be happening?

    Regards,

    Devin

    #81286

    Hi Devin,

    thanks for the reply.

    Our site is currently in a developing status, to show the issue please take a look here:

    http://hoteltechnik12.hotelundtechnik.de/?p=1277

    The first and second image of the gallery is identical. The first one is the article image and the second one part of the gallery. If I remove the picture from the gallery, the article image is removed as well. There seems no way to just show the article image once inside the gallery.

    Regards

    Marc

    #81287

    Hi Marc,

    I apologize for the delay in responding, I’m just getting a chance to catch up on open topics.

    I see what you mean now. Unfortunately I’m not quite sure how or if there is a way to change that behavior. I’ll need to tag the topic for another of the support crew to get a bit more incite.

    Regards,

    Devin

    #81288

    Afaik the gallery shortcode: http://codex.wordpress.org/Gallery_Shortcode comes with an “exclude” parameter. You can use it to exclude the first image from the gallery. Use it like:

    [gallery exclude="21"]

    and replace 21 with the attachment id of your image.

    #81289

    Thank you for the workaround Dude.

    This is only a partial and temporary workaround to this problem as the extra gallery image item inserted from the Featured Media also swaps the ALT text with CAPTION and omits the image TITLE at the bottom.

    #81290

    Hi!

    I’ll report this issue to Kriesi.

    Regards,

    Peter

    #81291

    Why is the Gallery Exclude shortcode does not work on my Flashlight theme?

    #81292

    Hey jlizardo04,

    If you are using WordPress 3.5 you can use the new Media Uploader/Image management tool. See: http://codex.wordpress.org/Inserting_Images_into_Posts_and_Pages

    All of the various options for using the shortcode can also be found here: http://codex.wordpress.org/Gallery_Shortcode

    If you are using exclude, make sure its in this format:

    [gallery exclude="21,32,43"]

    Regards,

    Devin

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Article image in image gallery’ is closed to new replies.