Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #189845

    Hey there,

    Trying to activate the WordPress SEO plugin by Yoast and for some reason my Avia Layout Builder refuses to load. I cannot view “screen options” or the information for Yoast – I see the title tag for “WordPress SEO by Yoast” on the “Edit Page” screen, below the “Avia Layout Builder” which shows the Layout Elements, but where the page information should be I just have a spinning “loading” icon.

    I’m on the latest Enfold ( 2.4.2 ) With the latest WordPress SEO plugin (1.4.19) and latest version of WP ( 3.7.1 ). The only plugins I have active are Akismet, bbPress, Disqus Comment System, Jetpack by WordPress.com and WooCommerce. Avia works with all these plugins running, and I’ve even tried disabling all plugins, then activating Yoast only. Same problem, Avia Layout Builder doesn’t load.

    #190273

    Hi,

    Can you create an administrator account and post it here as a private reply?

    Regards,
    Josue

    #190432
    This reply has been marked as private.
    #190472
    This reply has been marked as private.
    #190503

    Hi!

    If it still doesn’t work please try to add following code to functions.php

    
    add_action('init','remove_yoast_analysis');
    function remove_yoast_analysis(){
    remove_filter('wpseo_pre_analysis_post_content','avia_wpseo_pre_analysis_post_content_fix', 10, 1);
    }
    

    Best regards,
    Peter

    #191154
    This reply has been marked as private.
    #191222

    I said i performed some tests with the Yoast plugin enabled and it didn’t present any problems so far:

    http://www.creativmade.com/wp-admin/post.php?post=1979&action=edit&message=10

    Regards,
    Josue

    #194556

    I’m having the same issue — with Yoast SEO activated, Advanced Layout Builder doesn’t load on a page.

    As soon as I deactivate it, my content loads into Advanced Layout Builder.

    But Peter’s fix above is working for me.

    #196501
    This reply has been marked as private.
    #196743
    This reply has been marked as private.
    #197845

    Hey!

    I would suggest trying to disable all other plugins and then check things out. Then turn on Yoast and check again. By itself others have been able to get it working with the above fix.

    Best regards,
    Devin

    #197903
    This reply has been marked as private.
    #197905

    Here is a screenshot of the fix I applied, as recommended by Dude.

    http://screencast.com/t/nad6cmdt

    And my post above confirms that I’m still having the issue, contrary to what Josue has said.

    Please help, we are 3 weeks into this problem. thank you.

    • This reply was modified 10 months, 2 weeks ago by  kzpdesign.
    #197907

    I just created a new page with all plugins active with no issue. Please try using Chrome to make sure it isn’t a browser issue.

    #197912
    This reply has been marked as private.
    #197913

    And please note in the “Add New Page” screen I also cannot use the “Advanced Layout Editor” ie. Avia Layout Builder

    #197966

    Hey!

    I still can’t reproduce the issue and Yoast SEO works fine for me: http://www.screenr.com/f7wH
    However maybe it’s an issue with the memory limit. I installed a plugin which helps you to increase the allocated php memory: http://www.creativmade.com/wp-admin/options-general.php?page=change-mem – I set the memory from 64mb to 128MB.

    If the increased memory doesn’t solve the issue please try to test your website with another PC/Mac – maybe you’re using a browser extension which crashes Yoast SEO and you won’t notice the issue with another browser and/or PC which does not use the same browser extension.

    Cheers!
    Peter

    • This reply was modified 10 months, 2 weeks ago by  Devin.
    #198181

    Dude – your reply is set to “private” for me, and I cannot read it? Someone please let me know what OS and Browser they’re in, and if at all possible please provide screenshots of the Yoast SEO plugin + Avia Layout Builder working in the “edit page” screen of my site. I’ve tried on two different macs, running the latest version of 10.6, and 10.7 respectively, in the latest version of Chrome, Safari, and Firefox. All show the exact same problem, as the screenshots I have provided here.

    I can confirm this bug exists on 6 separate environments, yet now two moderators have said the site is working. Please confirm

    #198217

    Tested again just now. While fairly slow on the back end, its working even with WordPress SEO running:

    http://www.screenr.com/2MwH

    My guess on the backend speed is the combination of plugins running and server speed but it could also be running screenr at the same time as everything else I’m running locally right now.

    #198228

    Well hot nugget, we’re getting somewhere! Confirmed, your’s does work. Now in terms of trouble shooting, we’ve found the variable – your login. I just logged out, and logged into the account I created for you guys, and sure enough it also works for me!

    It will not work correctly, or at all, under my user account. Does that mean I need to delete mine and create a new one? Will that mess up the permissions of the rest of my wordpress site? Or is there a way you can fix it for my login? I can provide login info, Thanks

    #198423

    Very strange that it would be tied to a specific user. You could just create a new main admin to use and then either delete the previous one and assign the posts to the new account or just keep it around.

    I’ve never heard of a specific user getting an issue like that so I apologize for not suggesting that previously. Are you using any plugins that have specific user permission settings or anything like that?

    #198697

    Thanks Dude! I was having the same problem and your fix worked for me.

    Thanks,
    Corby

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Avia Advanced Editor doesn't load with WordPress SEO by Yoast Plugin’ is closed to new replies.