Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2411

    Hello,

    I have just activated Avia Feedback, but I am having some issues. The Add and Comments buttons do not function and instead take the user to the site home page. In addition, the Info button does not provide the hover information panel. This is a new Intranet site I am building so I cannot provide web access, but I have recorded what is happening, which you can see using the link below.

    http://www.acvm.co.uk/docs/avia.mov

    Thanks for your help.

    Jim

    #37882

    Oh, sorry but the Vote button also goes to the site Home Page.

    #37883

    Hi,

    I noticed a similar post and have found that my theme has this line in header.php. I have removed this but it then causes issues with the navigation and home page slider, both of which don’t work. However, Avia does work when this line is removed. Is it possible to amend Avia in some way to use this library?

    <!– Load jQuery –>

    <script type=”text/javascript” src=”http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js”></script>

    Thanks, Jim

    #37884

    Hey,

    you can try to remove change following code line in index.php (located in the plugin folder):

    //add javascript
    wp_enqueue_script('avia_feedback_box_js', AVIA_FEEDBACK_BOX_URL_FOLDER . 'feedbackbox.js', array('jquery'));

    to:

    //add javascript
    wp_enqueue_script('avia_feedback_box_js', AVIA_FEEDBACK_BOX_URL_FOLDER . 'feedbackbox.js');

    This will stop WP loading jquery automatically from another source.

    #37885

    Hi Dude,

    I’m afraid that made no difference.

    I don’t know PHP that well, but I’m wondering if it would be possible to add a condition to the header.php file for the theme so that this line is not invoked for the Feedback page e.g. if Page ID <> 78 then…

    <!– Load jQuery –>

    <script type=”text/javascript” src=”http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js”></script>

    Do you think that’s possible?

    Jim

    #37886

    Hi,

    Sorted it. I worked out the syntax for the theme header.php file so that on page 78 (the Feedback page), this line is not invoked.

    <?php if (!is_page(’78’)) { ?>

    <script type=”text/javascript” src=”http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js”></script>

    <?php } else {} ?>

    Thanks for your help and perseverance!

    Jim

    #37887

    Glad that you fixed the problem.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Avia Feedback Add, Comments and Info problems’ is closed to new replies.