Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #202

    The custom.js file is conflicting with another jquery file that I am using for navigation. Is there a way of bypassing this file and placing the Slider javascript directly into the the html file? I have tried this:

    <script type=”text/javascript”>

    $(document).ready(function(){

    $(‘#aviaslider’).aviaSlider({

    blockSize: {height: 80, width:80},

    transition: ‘slide’,

    display: ‘diagonaltop’,

    switchMovement: true

    });

    });

    </script>

    But it doesn’t work. I only need the Diagonal Blocks effect.

    The div #aviaslider is where the images are. I have tried leaving it as #diagonal-blocks, but it makes no difference.

    #30282

    that should work if you ask me. bypassing custom.js is of course possible.

    if you add that code snippet to your html source does it activate the slider? Or is nothing happening?

    #30283

    I have it kind of working now but, in Safari and Chrome browsers, the effect starts for the first line of boxes and then the rest of the image Pops into place.

    Sometimes also in Firefox until you reload the page.

    Here is the URL:

    http://www.mcpdesign.com.au/Clients/BoS/sliderInHtmlTest/

    Any ideas?

    Thanks, Steve.

    #30284

    Does disabling the custom navigation JS fixes the problem?

    You can try changing this:

    jQuery("#navigation").Smartmenu({animationDuration: 350});

    to this:

    $("'navigation').Smartmenu({animationDuration: 350});

    and moving it to within the opening / closing tags for the Avia slider.

    #30285

    Hey Steve, another idea would be to try to get everything to work on a blank html page with only the sliders css and javascript in place. once it works the way you want you move it to your homepage. if it doesnt work then we know that its not a slider bug but a javascript or css interfering. you can then try to partially remove javascript or css from the homepage to see what exactly is casuing the problems.

    I guess trial and error is the only thing we can try here…

    #30286

    So you think the SmartMenu might be the problem. I think I tried disabling everything but the slider, with no luck.

    I’ll try again tomorrow with your suggestions, and see how I go.

    Its midnight now… time for some sleep.

    Thanks for your time.

    Steve

    #30287

    Have a good night, and good luck hunting that bug down ;D

    #30288

    All fixed.

    It ended up being a stupid error on my part.

    I changed the reference to aviaslider from class to id… but didn’t change all the other references to aviaslider to match.

    Why it didn’t bother Firefox I don’t know.

    Sorry for wasting your time on this. Enjoy your weekend.

    Steve

    #30289

    Hey!

    Firefox was probably loading cached content, glad you figured it out.

    Best regards,

    James

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘avia slider’ is closed to new replies.