Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #293947

    HI,

    I set a Custom Background Image with Background Attachment: FIXED in a COLOR SECTION.
    In IPAD and IPHONE the same not work creating a strange effect where the image is stretched to fill the entire section.
    What can I do?

    #294478

    Hi CloudChoice!

    Please try adding following code to Quick CSS in Enfold theme options under General Styling tab

    @media only screen and (max-width: 990px) {
    .page-id-2392 div#av_section_2 { background-size: cover; }}

    Best regards,
    Yigit

    #294523

    HI,

    Thanks for the support. I applied this code:

    @media only screen and (max-width: 990px) {
    
    .page-id-2392 div#av_section_2 { 
    background-size: cover; }
    .page-id-734 div#av_section_8 { 
    background-size: cover; }
    }
    

    But there has been no visible change on the iPad.

    #294658

    Hi!

    Please try disabling CSS minifying feature on the plugin you are using. Code is currently not being applied.

    Regards,
    Yigit

    #294679

    HI,

    I disable the W3TC BUT the problem continues.

    #294815

    Hi!

    Thank you for the update.

    Are you referring to the NOSSA NUVEM section? If possible, please post a screenshot on how you want it to look like on iPad. It shows fine on iPad but it covers the whole section because of the image size. Please use this on Quick CSS or custom.css:

    @media only screen and (max-width: 990px) {
    .page-id-2392 div#av_section_2 {
    background-size: 50% !important;
    }
    }

    Cheers!
    Ismael

    #295033
    This reply has been marked as private.
    #295233

    Hi,

    Here is a picture comparing the two screens, computer x IPAD.

    computer x ipad

    Any suggestions?

    THANKS

    #296389

    Hi!

    What iPad version and iOS version is that happening on? I just tried it with mine and then a few emulators but didn’t get any issues.

    Cheers!
    Devin

    #296531

    HI,

    I change the logic.

    I left the background images in SCROLL, and in CSS I left:

    @media only screen and (min-width: 990px) {
    .responsive .page-id-2392 div#av_section_2 {
    background-attachment: fixed !important;
    }

    The problem is: in IPAD the image is not showing. when the width is above 999px.

    IPAD 16 GB Model A1396 IOS 7.1.2

    Any idea?

    #298123

    Try changing the file name of the image to sobre-nos.png without the accent. Wild guess but maybe iOS has an issue there.

    #298277
    This reply has been marked as private.
    #299752

    Hey!

    Please try adding following code to Quick CSS as well

    @media only screen and (max-width: 990px) {
    .avia-section { background-position: center center!important; }}

    Best regards,
    Yigit

    #299867

    Hi,

    Well, continues no working.
    The images are set for scroll.
    In IPAD the images not apear when i set the css for:

    .responsive .page-id-2392 div#av_section_2 {
    background-attachment: fixed!important;
    }
    Just in computer as FIXED.

    IF i set for:

    .responsive .avia-ipad .page-id-2392 div#av_section_2 {
    background-attachment: fixed !important;
    }

    the images appear scrool in IPAD BUT becomes scroll in computer.

    #299869

    In short:

    I can not get a picture FIXED in computer, and SCROLLING in IPAD.

    #303292

    Hi!

    Sorry for the late reply. You have following code in Quick CSS field

    @media only screen and (min-width: 990px) {
    .responsive .page-id-734 div#av_section_8 {
    background-attachment: fixed!important;
    }}

    please change it to following one

    @media only screen and (min-width: 1024px) {
    .responsive .page-id-734 div#av_section_8 {
    background-attachment: fixed!important;
    }}

    then add following code to Quick CSS

    @media only screen and (max-width: 1023px) {
    .avia-section { background-attachment: scroll !important; }}

    Regards,
    Yigit

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Background image in color section not working in IPHONE and IPAD’ is closed to new replies.