Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #19009

    I also get it when trying to edit a product.

    Not sure how to test this, I guess by turning the theme to another / default theme

    Im using flashlight v1.8 (the latest release)

    Wordpress v3.5 (the latest release)

    WooCommerce v1.6. 6 (the latest release)

    It doesn’t do it all the time, which is weird, roughly 90% of the time I click edit or add it goes to a white screen.

    I have activated error reporting,but nothing is showing, I have made an error log and this is reporting

    02-Jan-2013 14:44:52] PHP Warning: Invalid argument supplied for foreach() in /jamespictures.co.uk/wp-content/plugins/woocommerce/admin/post-types/writepanels/writepanel-product-type-variable.php on line 911

    [02-Jan-2013 15:20:58] PHP Parse error: syntax error, unexpected $end in /jamespictures.co.uk/wp-content/themes/flashlight/framework/php/class-megamenu.php on line 586

    Im going to change the theme now to see if the problem is resolved.

    I have Googled “writepanel-product-type-variable.php on line 911″ and there seems to be no other reports of the same problem, however if you Google “PHP Warning: Invalid argument supplied for foreach() woocommerce” it suggests that the theme is not fully compatable with woocommerce, so i thought I would post here to see if you guys knew any tips or advice.

    #101751

    So I changed the theme to Twenty Eleven default WP theme and I can add / edit products every time

    I dont understand how the admin area can be controlled by a theme, but it seems it works fine with the default WP theme.

    I have modified my theme a little from v1.7 flashlight but mainly only CSS and the helper-slideshow.php file.

    I will upload the latest v1.8 flashlight from scratch and see how that works, just to rule out any theme modifications I have done

    #101752

    Hi xGSTQ,

    The error doesn’t sound like anything I’ve come across but themes definitely can control all aspects of the wordpress admin (just as a general aside).

    I’ve tagged the topic for the head of support as well as the other support crew but definitely let us know if you have any specific set of actions that can cause the issue. Otherwise its a bit of a shot in the dark to try and debug it from the description so far.

    Regards,

    Devin

    #101753

    Hey!

    Did you try to increase the allocated php memory: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP ? I’d set it to 128M and check if this solves the issue.

    Best regards,

    Peter

    #101754

    Why would it be Memory Dude, curiosity more than anything ?

    I uploaded a clean copy of the flashlight theme and its still doing it

    I added

    define(‘WP_MEMORY_LIMIT’, ’96M’);

    to my wp-config.php file, ill test it now and get back to you.

    Not sure what my host has the memory restricted to, I will chuck them a ticket.

    #101755

    PHP Parse error: syntax error, unexpected $end in.. can be a random error which often occurs when the server stops to process a php file (not necessarily because of a syntax/code error – otherwise it would give you syntax error message – but because of other reasons). I can think of many reasons (corrupt/damaged php file, execution time, etc.) but the allocated memory is my personal favorite :)

    #101756

    Ah, makes sense

    Its doing it now when I eventually get to edit a product and then hit the update, goes to a the dreaded white screen

    I will ask the host :)

    #101757

    Hi,

    Have you tested if there are problems with the way you compressed the css/js files? There is no benefit to compress each individual file. You would be better off combining the css into one file and the js into two files. Then running page speed, and getting the end result. Otherwise there is no benefit since the total number of connections remains the same.

    Thanks,

    Nick

    #101758

    Hi Nick

    No ive not compressed any CSS or JS files, I tested the site with no modifications (default flashlight theme) and it was still doing it

    Im just in the process now of increasing the server memory, got to do it myself, dreamhost wash there hands so there is no comebacks on there part !! hehe

    http://wiki.dreamhost.com/Php.ini

    #101759

    So ive setup a manual php.ini and it was set the memory was set to 90MB as default

    I have changed it to128MB restarted the server and its still doing it.

    I found this thread,

    http://wordpress.org/support/topic/plugin-woocommerce-excelling-ecommerce-some-blank-admin-pages-after-moving-to-remote-server

    this IS MY problem… Ive contacted the host again

    Sorry about this, great support as usual :-)

    #101760

    Have you increased the memory in the config file for wordpress as well or do you think your host is not allowing the increase even with the ini setting?

    See: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Regards,

    Devin

    #101761

    Hi,

    This is your website http://www.jamespictures.co.uk/ , correct?

    The following theme files:

    http://www.jamespictures.co.uk/wp-content/themes/flashlight/css/W.shortcodes.css+slideshow.css,Mcc.eWQxSRuT2L.css.pagespeed.cf.y3xIkvMMVc.css

    http://www.jamespictures.co.uk/wp-content/themes/flashlight/js/avia.js,qver=1.pagespeed.jm.iUCBdapPyg.js

    do not come in that format with the theme. The pagespeed in the url may possibly mean they have been compressed.

    All the plugins css and js files are also compressed and all the images are changed to base64 code.

    What service are you using to do this?

    Please restore the original js and css files to see if that will take care of the problems.

    … or is this the Apache mod_pagespeed module? I thought it was still in Beta.

    Thanks,

    Nick

    #101762

    I have absolutely no idea !!! haha

    I have not compressed the files lol

    I think I have it fixed now, don’t ask me how, I had a few “old” plugins that was using depreciated functions so Ive updated them all and it seems to be working okay for now

    If the problem returns, I will remember your post Nick and look into this further..

    #101763

    Hi,

    Glad everything worked out.

    Thanks,

    Nick

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Blank White Page on Add Product Page in WooCommerce’ is closed to new replies.