Tagged: 

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #24650

    Hey there!

    I noticed that if I start a blogpost with a Dropcap as the first letter of a word, it doesn’t show up on the main Blog page listing the main entries.

    How do I solve the issue?

    Here is an example:

    Main page: http://vacationrentalsecrets.com/blog/

    look at the first post and see how the “h” of “Have” is not showing up.

    click on blogpost: http://vacationrentalsecrets.com/a-photo-book-of-your-home/

    and see the regular dropcap.

    Also, if you look at the Blog root up left, you see it says “Blog – Latest News”, something it did automatically. It redirects to the homepage, how do I change it to redirect to the main Blog page?

    Thanks.

    Antonio

    #124199

    Also, when I click on the ‘General’ link of the “Categories” in the sidebar, it opens up all the blogposts in that category in a single page, with the entire articles and without the possibility to leave any comment! I want the total opposite, that is the page to show only the excerpts of each article with the “read more” link. How do I do that?

    You can view the behavior here:

    http://vacationrentalsecrets.com/category/general/

    #124200

    1) The dropcaps seem to work for me just fine: http://www.screenr.com/N32H

    2) Open up wp-contentthemesenfoldindex.php and search for:

    $title  = __('Blog - Latest News', 'avia_framework'); //default blog title
    $t_link = home_url('/');

    Replace it with

    $title  = __('Blog - Latest News', 'avia_framework'); //default blog title
    $t_link = get_permalink();

    and replace “Blog – Latest News” with your custom text.

    3) Open up wp-contentthemesenfoldarchive.php and replace:

    global $avia_config, $more;

    with

    global $avia_config, $more;
    $avia_config['blog_content'] = 'excerpt_read_more';

    #124201

    Thanks Dude,

    I was able to fix the Dropcap last night by manually choosing the excerpt in the post back end, so that’s why it looked fine to you ;-)

    I copy/pasted the html part of the excerpt I wanted to show, so it did ok.

    I’ll follow your other tips!

    Again, thank you.

    Antonio

    #124202

    Hey Dude,

    when you say:

    and replace “Blog – Latest News” with your custom text.

    where do I find “Blog – Latest News”? I can’t find it in the index.php file.

    Also, I’ve replaced the lines you said but I still see the “Blog – Latest News” in each blogpost, so I don’t know how to change that.

    Most importantly, when I click on to “Blog – Latest News” i keep getting redirected to the site’s homepage, whereas I want it to redirect to the main Blog page. How do I do that?

    #124203

    Hi,

    If you want your images to be not so much blown up on the blog page. http://vacationrentalsecrets.com/blog/ Because some of your images you upload at 400px width and they get stretched out and become blurry. http://www.clipular.com/c?7530087=NjKFX29L_zQPxqkzE2m1jJz7mFE&f=.png Up to you.

    #top .fullsize .template-blog .big-preview.multi-big a, .fullsize div .template-blog .big-preview.multi-big a img {
    max-width: 400px;
    }


    “Blog – Latest News” can be accessed on line number 9 of single.php in root folder of the website:

    $title  = __('Blog - Latest News', 'avia_framework'); //default blog title

    Thanks,

    Nick

    #124204

    Hey Nick,

    your tip on the size of my images in the blog is absolutely outstanding! THANK YOU SO MUCH!

    It looks way better now! If I were to make the images slightly bigger would it be possible? Should I just change the max width say to 450px?

    For the “Blog-Latest News” how do I make it to redirect to the blog main page instead of my site’s homepage? It’s something I should definitely change. If someone wants to get back to the general blog while reading a single post and they click on the “Blog-Latest News” they’ll get to the homepage instead of the main Blog page.

    Any clue?

    Awesome help, thank you so much!

    Antonio

    #124205

    Hi,

    Its 1000 now, so you can put it as little or as big as you want, it just wont go over 1000px i think or a bit more.

    What do you have designated as the blog in Enfold > Theme Options? http://www.clipular.com/c?7811127=VVH9-zwgeQlBW54jFOMA2Pe3Cqc&f=.png

    Do you have the following on Settings > Reading http://www.clipular.com/c?7814108=0m4eeL_A6bfXbnm751XcRHe_Gwc&f=.png

    IF you don’t please change so that you do for the above settings. Right now your site thinks that the blog is the home page, that’s why its redirecting you there, so I think one of the above settings is different than what I displayed above.

    Thanks,

    Nick

    #124206

    Hi Nick,

    it was the first one you mentioned which was not set correctly! In the Enfold > Theme Options I had not selected any page in the Blog section. Now that I set “Blog” each first image in each post appearing on the main blog page is no longer centered, as it was nicely before with the nice author circular thumbnail appearing below. Now the image is on the left. How do I make them centered again all of them?

    Besides, there is again something that I don’t seem to understand: if I select the Blog page in the Enfold > Theme Options as per your screenshots, now the page shows again not just the list of blogposts with the excerpt as it was before (which is exactly what I wanted). It shows each article complete, one after the other, and without any possibility to add comments. I just simply want it to revert to the way it was before, so I guess I will “unselect” the Blog page in the Enfold > Theme Options, because I am currently getting a few visitors to the site and I don’t want to mess up too much!

    I’ll wait for your advice on how to fix the image and excerpts displaying as you will see them now that I will again “deselect” the Blog page option, rather than on the left (the image) and the full articles on such page.

    Thanks for your awesome help!

    Antonio

    #124207

    Hi,

    What’s even worse is that the link from the blog post still is pointing at the home page and not at the blog page, so the whole point of this exercise was useless. Since it is still not recognizing /blog/ as a blog.

    Are you sure you have it set as a blog in Enfold > Theme Options and you sure that Settings > Reading is same as above?

    What exactly is your blog page, what does it contain? Does it look at all like this-> http://www.clipular.com/c?7530131=I5mbXpfatfsUlZFvMLkMellgUGU&f=.png

    http://www.clipular.com/c?7811144=Sg-nkcBnRgsTnNhv5V2bCD3D9E4&f=.png

    Thanks,

    Nick

    #124208

    Hi Nick,

    yes, it does. It is set as you said, however when you looked a few minutes ago, you may have probably seen the “old” version, which I reset as I wrote, because I didn’t want the wrong pageview to appear.

    So now I will set it again as it should be, following your specifications and will leave it like this for the next 8 hours, hoping you’ll get access to it again before and can find out how to fix the issue.

    I am in Europe at the moment, so will look at the site again in the morning and I guess you are probably somewhere else, so you may hopefully get back to me with a solution by tomorrow (8 hrs from now) when I’ll have to revert to the “official” view, which is the one with the blog link not working.

    Thanks!

    #124209

    Hi,

    You are correct. Blog link is pointing where its supposed to. Nice. You can use this css to center your images

    #top .fullsize .template-blog .big-preview.multi-big {
    width: 50% !important;
    margin-right:auto;
    margin-left:auto;
    }

    Thanks,

    Nick

    Ya, I am in SE Asia on the beach with a beer and a laptop

    #124210

    Hi Nick,

    the css doesn’t work. The image is still on the left as it was. Besides, the page keeps showing the entire articles instead of the excerpts as it was before. How do I fix that?

    As I said, I am going to revert to the ‘old’ view (the one with the incorrect link), because at least it shows the page exactly as it should be.

    If there is a further fix you can provide me with I’ll wait for that, then try it out.

    Thanks!

    Antonio

    #124211

    Hi Antonio,

    I posted a screen shot early which shows the Blog customization page (the last one i posted) , have you selected to display the excerpt with more link. Please set up a dummy blog somewhere else on your site and block search engines, otherwise I am unable to help you. The CSS worked, though I can’t see again what the problem is.

    Thanks

    Nick

    #124212

    Hi Nick,

    here is the link to the dummy blog i just created (same exact options as for the regular blog):

    http://vacationrentalsecrets.com/blog2/

    I did follow all of your tips in each screenshot and apart from the Theme Options within Enfold for the blog which were not set to “Blog” initially and this only caused the “Blog – Latest News” link to go to my hompeage instread of the Blog homepgae, all the others where exactly already set as you later suggested and the page looked exactly as I wanted it to be.

    When I inserted the css inside the quick css field and saved it, the image gets to the left instead of being centered as it was correctly before. If I don’t insert anything in the quick css field, the image is correctly placed in the center.

    If I do not select “Blog” inside the Theme Options and leave it as is, the page looks perfect (without your css) but the link is still to the website homepage. If I do select “Blog”, then the image is no longer centered and the problem with the blog not showing the excerpts anymore but the entire articles in one single page is recurring.

    I filmed everything on my end here. You can watch it at the following link:

    http://youtu.be/H-NR3NitmYY

    Hope that helps…

    Thanks.

    Antonio

    #124213

    Hi,

    I fixed the code above, please use that instead, i forgot to add the margins before.

    —-

    Basically the left alligned images are that way for different reasons. The above code will fix the first one.

    In the code I see that some of the images are set inside paragraphs whose allignment is set to justify. So that’s something you should avoid doing.

    The middle image http://vacationrentalsecrets.com/wp-content/uploads/2013/06/html-e1371303141396.jpg is the one that is align: justify.

    <p style="text-align: justify;">image</p>

    How are you adding images to your posts? Are you making them feature images?

    Thanks,

    Nick

    #124214

    Hi Nick,

    thanks for the fix which now shows the image centered!

    I insert images into the post using the “add media” button so I can add as many as I want using a standard format blogpost. Then I chose the one I want as featured image and insert that as well.

    I see that all my images inserted within the justified paragraphs are justified too. How do I avoid inserting images justified? Is the fact that they are justified a big problem?

    Thanks for solving the image positon issue.

    How about the link to the main blog homepage (in the site now the link is ‘Blog2′) still bringing back to a page showing the entire articles in a row rather than just the excerpts with the read more link although that is selected correctly in the backend of the Blog2 page?

    Thanks,

    Antonio

    #124215

    Hi,

    You can keep your text justified. But the images should not be inside a paragraph tag.

    There is another way to do this. You can add 1 image to featured which will show on the main blog, but then for the individual page you can activate the template builder for posts https://vimeo.com/64996057

    Then you can add an image or slider for your main images and add the text element separately as you would do when you build pages.

    I am not sure what the deal with that link is, i need to look at your setup myself , please mail me credentials to usjahm (at) gmail (dot) com. since it works the way you say you have it set up for me locally and live.

    Thanks,

    Nick

    #124216

    HI Nick,

    I emailed you all the credentials. Hope that solves the problem with the link pointing to the wrong place and the wrong page showing all the articles regardless of the excerpts and read more link command only.

    Honestly, I don’t understand the video you sent me, it’s too techy for me and seems too complicated stuff…I don’t know what custom post types are nor what would I need them for, and I don’t understand your explanation above, so I may have to give up if I can’t solve this issue and simply revert back to the “old” Blog link which goes back to my homepage but at least if you click back on the blog you have the right page showing up.

    Antonio

    #124217

    Hi,

    Oh yeh, now I know who you are. I get many emails with a good number of them unable to show their post. I am looking now.

    Nick

Viewing 20 posts - 1 through 20 (of 20 total)

The topic ‘Blog: Dropcap in blogpost not shoing up in general blog page’ is closed to new replies.