Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #216068

    Hi,

    I’ve tried most of the answers I’ve found on your support articles but I can’t figure out how to get my blog posts to appear with only an excerpt and a “read more” link on the blog page.
    I’ve tried using the page builder and not selecting any blog page in the settings, I’ve tried using the blog post elements and selecting the excerpt within, I’ve tried a lot and this blog page is not responding to anything. I’ve even tried removing the sidebar and change the layout but for some reason, nothing changes. Even after a complete clean up of my browser’s cache, nothing seems to be affecting this blog page.

    I’ve already spent an hour trying different things, I’d love some tech help here.

    All I want is my posts to display like most other WP themes with just an excerpt and a “read more” or “continue reading” link, that’s it.

    I’m using Enfold v2.4.5, WP 3.8 and a child theme.

    Thank you very much in advance for your help!

    Aurelien

    #216120

    Hey TheAurelien!

    First, deselect the page you set as blog on “And where do you want to display the Blog?” option. Create a page then add the Blog Posts element. Configure the “Blog Content length” to Excerpt with Read More link. You can also use the <!–more–> tag or the Excerpt box enabled through Screen Options to manually specify an excerpt.

    Cheers!
    Ismael

    #220193

    Hi Ismael,

    Thank you very much for your help!

    On top of your suggestions, I had to go to Settings>Reading and select nothing as the “Blog” page to display.
    It must have created issues with the theme’s settings.

    With your help and this little tweak, the blog is now back to normal, displaying the articles and the “read more” link.

    Thank you very much!

    Aurelien

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Blog Excerpt not working’ is closed to new replies.