Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #8124

    Hi.

    I have a couple of questions about featured images for the blog.

    I added a featured image to a blog post via the ‘Featured Media’ section in the post editor. However, the image is displaying full size in the front-end. Of course, I can just resize and/or crop images for this purpose but as it will actually be my client who manages the site, I didn’t want to have to tell them that they have to upload the images, a certain exact size and dimensions.

    I can’t help but feel that I am missing something as most themes I have used in the past (and currently) for other projects have a thumbnail/featured image sizes set for sections such as the blog roll.

    Also, if the placement of the featured image has to be where is currently is (without significant customization), that’s not a disaster, however, I really would prefer it to be on the left, beside the post title, as this would allow more posts to seen with less scrolling.

    Lastly, is it possible to ‘turn off’ the featured image when viewing the actual post.

    So, in a nutshell:

    1. Is it possible for blog post featured images (on the main blog page) to be constrained (cropped if necessary) to a set size?

    2. Does the theme allow for repositioning the featured images (on the main blog page) to beside the post title?

    3. Can the featured image be disabled on the post page?

    Here is a link to the general type of layout I’m getting at: http://sunstarcreative.co.uk/blog/

    and a screen cap showing what I currently have (you can see the image for the Hello World post is really big) as well as where I would ideally prefer the featured image to be located: https://skitch.com/kickmuck/ga4yf/blog-quarky-science

    Thanks a lot in advance.

    #60398

    Hey,

    1) Yes – you can change the image size in functions.php – if you’d like to activate the crop function replace:

    $avia_config['imgSize']['post-format-image'] 	= array('width'=>630, 'height'=>999, 'crop'=>false);

    with:

    $avia_config['imgSize']['post-format-image'] 	= array('width'=>630, 'height'=>999, 'crop'=>true);

    Afterwards regenerate the thumbnails with: http://wordpress.org/extend/plugins/regenerate-thumbnails/

    2) This is not easily possible because of the grid/div structure which is currently used. If you’re familiar with css you can try to float the elements however this will propably break the responsive design.

    3) Yes – open up includes/format-standard.php and replace:

    $slider = new avia_slideshow(get_the_ID());
    if($slider) echo $slider->display();

    with:

    if(! is_single()){
    $slider = new avia_slideshow(get_the_ID());
    if($slider) echo $slider->display();
    }

    #60399

    Hey Dude.

    Thanks sooo much for the fast reply and ‘how-tos’.

    Greatly appreciated.

    Cheers,

    David

    #60400

    Hi again Dude.

    I am having problems with 1.

    I replaced the code in functions.php with the one provided, regenerated the thumbs (I already have that plugin installed, which was handy) but the ‘featured image’ is still really big. I noticed that the height is ‘height’=>999 in the replacement code, so tried reducing that to ‘height’=>300 in case that was the issue as well as removing and readding the featured image but with no success.

    Interestingly, as the blog page loads, there is a brief preload ‘image’ that seems to be the correct height but when the page finishes loading, the large, uncropped image appears.

    Here’s a link to the blog: http://quarky.sunstarclient.com/blog/

    Thanks,

    David

    #60401

    Did you regenerate the thumbnails again after you changed the size? Did you clear all caches?

    #60402

    I did indeed, a few times and even tried a couple of different browsers (FF Chrome and Safari).

    That said, I tried adding a completely different image to the other existing post and it seems to be fine. I guess there was a problem due to the fact the dinosaur image was already in the media library. Not sure why, but maybe something to do with that as it is still not right and the other is fine.

    Anyway, thanks for your help dude.

    Cheers,

    David

    #60403

    Hi Again.

    While doing some work on the website I created another test blog post and am having the same problem again i.e. the image is appearing really big (not cropped).

    The image is a new one uploaded to the media files.

    Here is the code from functions.php relevant to this:

    $avia_config = array('width'=>630, 'height'=>300, 'crop'=>true); // big images for post format image and gallery posts

    And the code from format-standard.php:

    if(! is_single()){

    $slider = new avia_slideshow(get_the_ID());

    if($slider) echo $slider->display();

    }

    Also, I’ve regenerated the thumbs, just to be safe.

    Here is a link to the site:

    http://quarky.sunstarclient.com/blog/

    I had hoped to show the site to the client today so would be extremely grateful if you could help me figure this one out.

    Thanks!

    David

    #60404

    Hi.

    Other than having the same problem described above, I am also having problems with the portfolio images.

    Please see: quarky.sunstarclient.com/projects/test-project/

    If you click on the image, you’ll see that it is quite a small image so don’t know why it’s appearing so large. At the very least I would like it to be cropped like: http://www.kriesi.at/themes/propulsion/template-files/portfolio-1-column/, which is essentially the same as I want for the blog.

    I don’t know if this problem and the one above (in my previous message) are related but I really need to sort this out.

    Thanks!

    David

    #60405

    I’ve had to remove the problem images from the website as I need to present it to my client.

    I’ve taken screen captures of the two problem images/areas so you can see what the problem is.

    Blog Featured Image: https://skitch.com/kickmuck/ghb3r/blog-quarky-science

    Portfolio (Projects on website): https://skitch.com/kickmuck/ghb24/projects-quarky-science

    I hope you can help with this.

    Thanks,

    David

    #60406

    Hi.

    Sorry to nag but are you able to help with this problem?

    Thanks.

    #60407

    Hi,

    Sorry for the delay.

    My first idea would be what Dude suggested.

    Since that didn’t work I honestly don’t know why this is happening, if you’re using images with correct dimensions (or bigger) it should be filled in fine. As I don’t know which sizes your original images are I can’t tell/check the code.

    Another reason could be that you’re running a plugin that interferes with the styling, but again – I can’t check this without the images being online.

    #60408

    I’m having the same problem. I assumed that the featured image, single image or any image added to the portfolio (it seems to me) has to be added as part of a “slideshow” if you want a thumbnail to show up in a gallery, widget or any sort of index. It’s the only way to add a featured image (that I can tell).

    It appears that you have to choose one of the 3 slide options, all of which want to stretch the image the full width of page/content space. So even if the real image is only 400 px wide, it’s going to stretch the whole image to fill up slider space. Is that right? If you click on the slide show image, it will open the pop-up that shows the actual sized image. Is there no way just to show the real image in the first place and skip the “slideshow” on the portfolio post?

    The default is 930 pixels wide? We have to change that in functions.php? That’s really odd. Who wants a giant slider on every portfolio post? This can’t be right.

    Maybe it was fixed on an update that I don’t know about.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Blog Featured Image’ is closed to new replies.