Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26456

    Hey,

    I’ve tried everything but I can’t seem to be able to remove the footer widget section on my blog and blog posts.

    What do I do?

    Thanks,

    Mika

    #130464

    Hi,

    You might actually need to alter the default settings on Enfold > Footer > Default Footer Widgets & Socket Settings > Select “Display only the socket (no footer widgets)” then force the other pages to Display sockets & footer widgets. I’ll tag Kriesi.

    Regards,

    Ismael

    #130465

    Hmm, the footer widget is still there unfortunately.

    #130466

    Hi,

    Further to this, I find no matter which of the 4 options I choose in Default Footer Widgets & Socket Settings, there are no changes to the footer. In addition, there are no footers displayed when I choose a tag.

    Thanks.

    Marshall

    #130467

    Probably the problem is that you already saved an individual page setting (post meta value) for all pages. Try to add following code to the bottom of functions.php

    add_action( 'admin_init', 'avia_remove_meta');
    function avia_remove_meta()
    {
    $post_types = array('post','page','portfolio');
    $count = 0;

    //iterate over each post type
    foreach($post_types as $type)
    {
    //get all posts of a certain type
    $the_query = new WP_Query( array('post_type' => $type, 'posts_per_page'=>-1) );

    //check if any post were retrieved
    if(!empty($the_query->posts))
    {
    //iterate over each post and check if the post has a gallery key
    foreach($the_query->posts as $entry)
    {
    //since there might be hundreds of posts make sure php doesnt time out
    @set_time_limit(45);
    $success = delete_post_meta($entry->ID, 'footer');
    }

    }
    }
    }

    to reset these individual settings. Then load the admin page (can take some time) and remove the code again. Afterwards go to Enfold > Footer > Default Footer Widgets & Socket Settings and select “Display only the socket (no footer widgets)” or any other option.

    #130468

    It worked! Thanks!

    #130469

    Hey,

    Glad it is fixed. :)

    Cheers,

    Ismael

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Blog Footer Widget Issue’ is closed to new replies.