Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10230

    Hi everyone,

    I am still a novice when it comes WordPress. This is a new thread about the same issue. I still can not figure out why my blog posts don’t show up on my “blog” page. Take a look at http://www.kbctech.com. What’s funny is I have thee same theme installed on my personal site and it works just fine — take a look : http://www.jeromesouth.com . Does anyone know what’s broken about my theme?

    Please help me on this.

    All the best,

    Jerome South

    #67332

    Hi!

    I’m not sure which configuration you use but try to set the blog page via the theme options panel and make sure you don’t use a static home page (Settings > Reading).

    Best regards,

    Peter

    #67333

    Hi Peter,

    Thanks for the reply. This website is being used for my company so they want the blog on another page accessible through the menu. That’s why I customized the the front page (index.php) a bit and removed the loop so it doesn’t display posts. I want those on another page (kbctech.com/blog). Hope this makes sense. I checked reading settings and not set to static home page. Any more great advise? Thank you.

    Jerome

    #67334

    Hey!

    I wouldnt recommend to change anything in the theme files to accomplish this. The method you should use is this:

    create 2 pages: a “welcome” page and a “blog” page. not go to the wordpress backend to the broadscope option page. At frontpage settings choose “welcome”. A second dropdown for the Blog page will appear, here you can choose the “blog” page.

    Now go to appearance->menus and create a new menu to your liking with links to home, blog page etc

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Blog loop not showing posts on "blog" page – help pleas!’ is closed to new replies.