Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20976

    Hey guys. I am developing locally, so I can’t post the site, but my blog wont show up. If I ad a blog element to a template in the template builder then the blog posts show up. But I have created a page named Blog. then assigned it as my posts page. and made a menu item blog and linked it to the page blog. But when I click on it I just go to a blank url screen. “localhost/blog/ it is just white. Any thoughts, in a blind world.

    #109890

    Hi allegrabillings,

    First try going to the WordPress Settings>Permalinks and changing it to default. Then check out the blog page and see if you are able to pull it up.

    If not, then you may have an issue with the local host server set up. You can also try changing the settings in WordPress Settings>reading so that it isn’t set to the default option but instead define the home page and blog page using the wordpress settings and not using the thme settings.

    Regards,

    Devin

    #109891

    Okay well I got it working. I had to make a custom theme template and give it a blog element. then I had to uncheck the option in the wordpress settings>reading that specifies the blog page (leave blank) and then it showed up. if I specify it in the wordpress settings it doesn’t work.

    But a weird side note. If I don’t assign the frontpage there then that doesn’t work. It is behaving the opposite. I have been doing a bunch of testing so my database could be a bit wonky at this point too.

    Side question. If I make a page names blog – and it gets a permalink of …/blog. then I delete the page and make a new one it gets permalink of …/blog-2 is there a way to change that. If I use the obvious change permalike setting and change to just blog it wont take it. I am assuming the database can only have one entry even if it is deleted? Can this be rectified without wiping the database and starting over?

    #109892

    The setting in Settings>reading should be set to default where you don’t define the home page and blog page specifically since the theme does that for you in the main theme settings (front page and then blog). I’ve seen it a few times where it doesn’t work correctly for some servers so sometimes it needs to instead be done in the actual wordpress settings but it should really be only one of the two ever.

    For the permalink, items in your trash count as still having a slug name. So the blog in your trash will make it so you can’t have a new blog page until it gets deleted. Then you can re-name the slug for the new blog from blog2 to just blog again.

    Regards,

    Devin

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘blog not showing up’ is closed to new replies.