Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3226

    Hey I’m having trouble getting a link to my Blog from the main page to work.

    I created a page that I wanted to use to link to my blog. On this page I created an excerpt and set the template to BLOG

    I then went to the Mainpage Options tab and set “How to populate Mainpage Columns 3″ to Page > Blog

    I then went to the Blog Options tab and set “The Page you choose here will display the Blog in addition to the normal page content:” to the Blog page

    When I click on the Blog link on the mainpage it sends me to a page that says this:

    Nothing Found

    Sorry, no posts matched your criteria.

    Am I doing something wrong??

    Here’s my site, thanks for the help: http://txrocks.net/resume/

    #41282

    Hey,

    It looks like your blog link: http://txrocks.net/resume/category/blog/ is working at the moment, if it stops working again go to your Permalink Setting page (WP Admin > Settings > Permalinks) and click save. This will flush the rewrite rules and hopefully fix the problem.

    Just as an FYI, on your site the blog page is a category archive and not a page. You can change this to a page by adding a page called “Blog” and selecting the blog page template.

    James

    #41283

    Thanks for the response James.

    I guess I worded my above statement incorrectly.

    My blog at http://txrocks.net/resume/category/blog/ works. I tried creating a page in the 3rd column on my mainpage that would link to my blog at http://txrocks.net/resume/category/blog/. When you click on this page it sends you to this page: http://txrocks.net/resume/blog/. When you arrive there it gives the message: Nothing Found

    Sorry, no posts matched your criteria.

    I set the template to “Blog” and I set the Blog Settings to point to that page. Am I doing something wrong?

    I reset my perma-links and it’s still doing the same thing.

    #41284

    The problem is that your Blog page is a category and not a “blog”. To set up a blog page go to Display Options > Blog Options and select a page which should be the dedicated blog page (please don’t work with page templates). Then point your frontpage link to your blog page. At the moment your blog page is a archive/category page (I can see it because of the category slug in the permalink).

    #41285

    Ok.

    I deleted my page at: http://txrocks.net/resume/blog/

    And I created a new ‘blog’ and set the template to default

    I then went to Display Options > Blog Options and selected the new Blog page that I created

    I then went to Display Options > Mainpage Options and selected the Blog page as well

    Still having the same problem.

    I’m having a problem turning my archive/category page into an actual page I suppose, because I’ve followed your directions and it’s still giving me the same problem.

    #41286

    Hey,

    Can you set me up a WP admin account and email the details to support {at} jamesmorrisondesign {dot} com with the subject:

    Kriesi | Display | Blog Page Link From Main Page Not Working

    with a link to this topic and I’ll have a look over your site.

    James

    #41287

    Hey James,

    I created an Admin account for you. Were you able to check out my site?

    Thanks,

    Patrick

    #41288

    Hey,

    Problem solved (I think) – details are in the email I sent you.

    Please reply by email if you need further help with this subject or open a new topic if this is not the same topic.

    James

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Blog Page link from Main Page not working’ is closed to new replies.