Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20953

    Hi ´

    I am having some problems with my blog.

    1. I am missing the place where i can select which page to display as my Blog Page.

    2. Can I add a right sidebar to my Blog Page? I don’t seem to be able to…

    3. When I add images to the background slideshow on my blog page the default slideshow shows up.

    And a last question:

    How can I replace the rss and twitter icons (and links) with LinkedIn and Pinterest?

    Thanks

    #109776

    Hi Ikkeenpind,

    1) In the main theme options once you select the homepage, you can select the page to hold the blog. If that isn’t happening, disable any active plugins you have running, refresh your view of the admin page and try it again.

    2) Yes, on the page you have designated as the blog page there is a metabox labeled “Layout Options” on the right hand side. Use the dropdown for “Do you want to display a sidebar?” and select Yes, display right sidebar.

    3) Make sure you have the gallery layout settings set to display your gallery images as a background slider.

    The social icons can be replaced in the theme files by opening sidebar.php. Look for:

    echo "	</ul><!-- end social_bookmarks-->";

    Replace it with:

    ?>
    <li class="linkedin"><a href="http://yoursociallink.com">LinkedIn</a></li>
    <li class="pinterest"><a href="http://yoursociallink.com">Pinterest</a></li>
    <?php
    echo " </ul><!-- end social_bookmarks-->";

    Now just above there you need to remove the rss, so find this line and delete it:

    echo " <li class='rss'><a href='".avia_get_option('feedburner',get_bloginfo('rss2_url'))."'>RSS</a></li>";

    The last step is replace the twitter and rss icons with your own. So add the following to your Quick CSS in the styling tab of the theme options:

    .social_bookmarks .linkedin a{background: transparent url(yourimageurl.png) 0 0  no-repeat;}
    .social_bookmarks .pinterest a{background: transparent url(yourimageurl.png) 0 0 no-repeat;}

    The “yourimageurl.png” would be the location on your server of the icon for each of the links.

    Regards,

    Devin

    #109777

    1) I disabled all plugins but still no blog option…. the only way I can choose a blog page is under reading settings which is okay if haven’t had the other problems as well.

    2) I have chosen “Yes, display right sidebar”, and I have given my blog page a new widget area under Sidebar, and I have chosen the widget to be displayed in the sidebar, but there is still no sidebar.

    3) I have chosen “As background slider only” but it is still the default slideshow that is displayed.

    #109778

    And the social icon thing doesn’t seem to work either

    it is still the old icons linking to twitter and rss

    #109779

    Sounds like things are not working at all correctly with your installation. Are you running wordpress 3.5.1 and Flashlight 2.2?

    If you can create a temporary admin account for me I’ll log in and take a look. At the very least the social icon change should be live since you are modifying the actual files for the theme and deleting the rss icon code from the sidebar.php would be it isn’t possible for it to show up.

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Blog problems’ is closed to new replies.