Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #16855

    Hi – my blog archive page is acting funky. I have it set up to display the category blog and I am having the following two anomalies:

    My featured image thumbnails on the overview page are getting cut. I did not change, as far as I know, any css regarding this display

    The other issue, my “read more” much like the demo is not displaying automatically

    Here is the offending page: http://www.dataccount.com/category/blog/

    Thanks for your help

    Nancy

    #93141

    Hi,

    1.) Go to css folder then edit the style that you are currently using then add this at the very bottom.

    .framed_one_fourth {
    width: 208px!important;
    }

    2.) Open template-blog.php and find this code

    the_content(__('Read more »','avisio')); ?>

    Replace it with this

    the_content('Read more...'); ?>

    You need to use <!– more –> on your post editor to designate the excerpt.

    Regards,

    Ismael

    #93142

    Okay – issue one fixed, the featured images on the blog summary page are displaying correctly and not getting chopped. The other issue is still an issue. I made the changes as instructed and added the comment in the blog post itself indicate the excerpt, but no go.

    I want to be able to control where the excerpt will occur and I want the read more button as displayed in the demo. Right now, I only have an elipsis and it isn’t even clickable.

    Any other suggestions?

    #93143

    Try following – in replace

    the_content(__('Read more »','avisio')); ?>

    with:

    the_excerpt();
    echo "<a href='".get_permalink()."' class='more-link'>".__('Read more','avisio')."</a>";
    ?>

    You can now use the excerpt textarea/option field to control the content of the excerpt and the read more button should be displayed properly.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Blog Summary Display Issues’ is closed to new replies.