Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #17914

    My blog in Propulsion is allocated on a page called “Magazine”, which should be splitted up in “Blog” and “Forum”. In the theme options, I choose “Magazine” as Blogpage. Theme options default page layout is “right sidebar”.

    To have than on that “Magazine” page an overview of all blogposts with a sidebar, I generated a custom template with a right sidebar by using the template builder. Now, I wanted to have a view on the single blogpost without having a sidebar. For that reason I generated again a custom template without sidebar (Fullwidth). But the sidebar still shows-up.

    Why?

    #97464

    Hi PLUP_Planet_Upcycling,

    You need to set each individual blog post to have No Sidebar. On the individual post go to the meta box labeled “Layout”. It should be just below the Categories and Tags boxes. From the dropdown select “No Sidebar” and then save the post.

    Regards,

    Devin

    #97465

    Hi Devin,

    thank you for feedback. I did so. The sidebar went away than, but the text flows still only in the middle column. Not “fullwidth”. For that reason I created the new template for Blogpost, set layout on “fullwidth” and add the elements “heading” and “blog”. But when I choose this template in the Layout meta box, I have a sidebar AND when I click on “Read more” to come to the whole article it doesn’t move me to the article view.

    Regards,

    Frank

    #97466

    PS Default blog layout in “theme options” – “layout & settings” is right sidebar. But there you have only the choice between right or left sidebar?

    Frank

    #97467

    Hi,

    Can you give us a link to your website?

    Regards,

    Ismael

    #97468

    http://www.planet-upcycling.net

    Go to: http://www.planet-upcycling.net/?page_id=396 which is the overview of blogposts and then click on “Weiterlesen –>” below posts.

    The page should not be live for public yet because I’m still working on it. For you I have turned off the under construction sign for a while. My work is now live. So, please let know when you could have had a look so I I can turn on the construction sign again.

    Thank you.

    Frank

    #97469

    Hi PLUP_Planet_Upcycling,

    Kindly add this code on your Quick CSS or custom.css:

    .template-blog .six.units.entry-content {
    width: 690px;
    }

    or, if the code above doesn’t work, try this code instead:

    .template-blog .six.units.entry-content {
    width: 690px !important;
    }

    Regards,

    Ismael

    #97470

    Hi Ismael,

    both are working well for the blogpost view of a single article. But now the overview of all articles in the blog (blog starting page) is displaced. Text of the excerpt goes behind the sidebar and start on the total left side. This was ok as it was before?

    Regards,

    Frank

    #97471

    Text behind the sidebar in blog overview page is only when using justified setting. Template of the blogpage is “Default”.

    #97472

    Hi PLUP_Planet_Upcycling,

    Try to change the code I gave you, with this code:

    template-single-blog .six.units.entry-content {
    width: 690px;
    }

    or, if the code above doesn’t work, try this code instead (the code above is more recommended):

    template-single-blog .six.units.entry-content {
    width: 690px !important;
    }

    However, make sure all single blog pages are not using a sidebar, or it will be messed up just like this page: http://www.planet-upcycling.net/?p=1034

    Regards,

    Ismael

    #97473

    Hi Ismael,

    no, it doesn’t work. Now it is the same like before. Overview is ok, single blogpost view shows only text in the middle.

    Article format is set in the metabox of each article to “no sidebar”.

    Regards,

    Frank

    #97474

    Sorry guys, since I have now already received a comment in the blog on the half built page, I need to turn on the “under construction” sign again. I guess the problem is clear. If you want, I can send you some screenshots or a log-in. In that case please mail to: F (Email address hidden if logged out)

    Thank you.

    Frank

    #97475

    Hi Frank,

    Just sent you a mail. :)

    Regards,

    Ismael

    #97476

    Hi Ismael,

    could you find out something?

    Regards,

    Frank

    #97477

    Hi,

    Sorry, I can also take a peek. My email is usjahm (aaattt) gmail (dddooottt) com. Please reference this post in the email.

    Thanks,

    Nick

    #97478

    Hi Nick,

    just sent it.

    Regards,

    Frank

    #97479

    Something new?

    Regards,

    Frank

    #97480

    Hi,

    I am in there, please bare with me as I can’t read German and trying to examine it without breaking anything. :)

    Thanks,

    Nick

    #97481

    Hi,

    Was this the look that you were looking for?

    Please don’t forget to delete the temp account.

    [EDIT: I fixed the problem with CSS similar to above]

    Thanks,

    Nick

    #97482

    Yes, great support. Thank you very much Nick!

    Just delete the temp account.

    Frank

    #97483

    Hi,

    I can’t delete the account I am logged under. You will have to delete the temp account with the main admin account. Glad that everything worked.

    :)

    Thanks!

    Nick

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Blogpost without sidebar (Blog Overview with sidebar)’ is closed to new replies.