Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #7889


    I’m having a problem with the Mega Menu on Brightbox.

    Two links (the ones marked on the menu as Mega Menu links) are showing as if they were the active page. I mean, they’re highlighted.

    In a previous mockup of the same site, built in another server this won’t happen.

    Also, it only happens on the home page, which is a page built with the Brigthtbox template builder.

    In order to clarify, I’m including the url of a snapshot of the upper portion of the home page. It’s the latest version of Brightbox, 1.2.3 and WP 3.3.

    url is

    snapshot url:

    Thanks in advance for any help.



    this is a bug caused by WP3.3 and not a theme bug. WP adds the “current_menu_item” class to several menu items – thats’s why several items appear with the blue box around it. We need to wait for the next WP update which will fix this problem.


    Thanks for the update.

    One more question: the problem only appears on the Home page, it doesn’t show up on the inside pages, any idea what might this happen?


    Home: (two active pages selected but home NOT selected) (wrong)

    Interior page: (only active page selected) (right)



    a new version of WordPress was just released, I haven’t tested if it solves anything yet but I found this in the update log:

    current-menu-item and current_page_item classes incorrectly added to custom menu items with no URL value.

    ^This makes me believe your issue will be solved with updating to the most recent WordPress version :)


    Hello Chris,

    you were right on the money! As soon as I upgraded to WP 3.3.1 the problem disappeared.

    Thank you,


Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Brightbox – Mega Menu showing two active links in home page only’ is closed to new replies.