Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #3584

    Broadscope supports .po/.mo translation files. To use them please unzip the po file and open it with Poedit (http://www.poedit.net/download.php). Now translate all text strings. Save the translated text strings under following name “your-language-shortcut.po” . Assuming you come from Sweden save it under: sv_SE.po, if you’re from Germany de_DE.po

    A list of language shortcodes can be found here: http://codex.wordpress.org/WordPress_in_Your_Language

    At least you must save/upload/copy the generated .mo file in your theme main folder.

    Attention: WordPress will only use the translation file if you set the right backend language: http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    Please upload your translated files (by using one click hosters like http://mediafire.com ) and post a link here. It will save other users a lot of time and maybe you’ll get some feedback (i.e. suggestions how to improve your translation, etc.).

    Default, untouched english po file – use it to translate Broadscope to your language: http://www.mediafire.com/?da25r71hjt3767c

    Other languages:

    ………………………

    German po/mo files (just place them in your theme main directory): http://www.mediafire.com/?l8a8pgug3y6skdw

    Spanish: http://www.mediafire.com/?epgktz19hulip21

    French (90% translated): http://www.mediafire.com/?w9cjyt5h8ft8et8

    Slovenian (82% translated): http://www.mediafire.com/?fkupgi7a9o6gls8

    #42858

    Hey,

    Bought a theme, “Broadscope”, i took the most recent language files (swedish) from wordpress.org, and uploaded them into the theme main folder, but nothing happens. I also tried to put them in the directory with all themes, but no.. :(

    The pages language is swedish, it’s only some pages which i need those files to change the language with. (broadscope pages…)

    #42859

    Hi,

    I’m in the same situation. I have traslated into Spanish the untouched english po file with poedit and uploaded .po/mo generated to the language folder, and nothing happens.

    Anyway, you can find the traslated .po file in http://www.mediafire.com/?epgktz19hulip21

    cheers

    #42860

    Did you add

    define ('WPLANG', 'my-language shortcode');

    to your wp-config.php file? You can see the language shortcodes here: http://codex.wordpress.org/WordPress_in_Your_Language

    i.e. if you’re from Sweden it would look like:

    define ('WPLANG', 'sv_SE');

    #42861

    Yes, of course.

    The other pages workes properly…

    #42862

    I did the same it didn’t work, as steelduck.

    #42863

    Strange. I don’t know why it doesn’t work. Normally it’s a straight forward thing (just name the generated .mo file de_DE.mo, sv_SE.mo, etc). and upload it to the main folder of the theme.

    #42864

    Hi Kriesi!

    Thanks a lot for the great work. Just bought the theme yesterday and we´re going to build our product website with your theme. Now I´m wondering if the theme translation is for the frontend language slugs only or perhaps also for the backend options? I´m using the german translation, you offered above via mediafire.

    Kind regards from germany!

    #42865

    Hey,

    only the frontend is translation ready (backend is always in English)

    #42867

    French version, 90% translated

    http://www.mediafire.com/?w9cjyt5h8ft8et8

    #42868

    Thanks :)

    #42869

    This almost works. For example, I translated “Tags” (to “Značke”) and my site still shows the word in eng. “Categories” is nowhere to be found in default.po, but “Comments” (and mostly everything else) is shown nicely translated.

    BTW, Slovenian version, 82% translated

    http://www.mediafire.com/?fkupgi7a9o6gls8

    #42870

    Hey,

    Kriesi forgot to include this word – you can translate in manually by editing loop-index.php and loop-archive.php. Search for:

    <strong>Categories:</strong>

    change the text to your needs.

    #42871

    Does this works with habitat?

    #42872

    Yes – Just follow the instructions in the first post but use the po file I posted in the other thread…

    #42873

    Hello Dude or Kriesi or anybody else at the team,

    Thanks to your wonderfull help I managed to translate almost all the theme in Dutch, except for the part shown below, it’s in the searchresultpage if nothing is found, can you please explain me how to do this?

    “Feel like browsing some posts or pages instead?” followed by three columns named: “Archive”, “categories” and “Pages”

    Thanks in advance!

    #42874

    You can fix it by modifying includesloop-search.php – open up the file and replace:

    <h3 class=''><?php _e('Feel like browsing some posts instead?'); ?></h3>

    with:

    <h3 class=''><?php _e('Feel like browsing some posts instead?', 'avia_framework'); ?></h3>

    #42875

    Hi Dude, thanks for your fast respons, that worked out very well.

    JUST ONE OTHER THING: the heads in the 3 columns following are still in English, I would like them to be:

    Archief, categorieën en pagina’s (in Dutch)

    #42876

    Open up includes/register-widget-area.php and search for following code lines:

    echo"<h3>Archive</h3>";

    echo"<h3>Categories</h3>";

    echo"<h3>Pages</h3>";

    echo"<h3>Bookmarks</h3>";

    You can translate the text :)

    #42877

    I am trying to translate the theme bit it’s impossible. I have done all these wordpess settings but nothing works. For example i am trying to translate the category page http://www.xaazar.com/posts/category/forex/ what do u suggest me ?

    #42878

    Hi,

    Are you referring to the “Archive for category” text. Go to framework > php folder. Open function-set-avia-frontend.php and find this code

    function avia_which_archive()

    Change the text from there.

    Regards,

    Ismael

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Broadscope translation files’ is closed to new replies.