Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #18399

    Hi guys,

    Recently purchaserd Coherence theme and loving it.

    However, I think I have noticed a small bug in the contact form.

    If I add text to the Form Element Label for the Text Area (the area you type your email message in) that is more than a few words, it fails to send the emails Text Area with the email.

    For instance, I had about two sentences in the Label for the Text Area field, and it never sent any of the body of the emails – just name, email, subject etc.

    But if I keep that fields label short, say a couple of words it seems to work fine.

    Have you tested this?

    Thanks for your help.




    Maybe you’re using special characters in your text (like ä,ö,ü,ß, etc.)? These characters can break the contact form field submission.

    Best regards,



    HI Peter,

    Nope, didn’t have any special characters that I can remember, just plain english characters, no symbols etc. It seemed it was purely the length of text in the Label field, not the actual Text Area field, which i know sounds weird. Have you tested the length with say two or three sentances as the label?




    No, not yet. However I know that Kriesi uses the label text for the field names – thus if you enter 3-4 sentences the field name (eg of the text input field, the dropdown, etc.) is probably too long and then the php post process will not work properly. I.e. on this page: the name of the checkbox field at the buttom is: “avia_i_have_read_the_general_terms_and_conditions_and_i_agree” – so all label characters are also part of the field name. I’ll ask Kriesi to look into it and to find another way of generating the field names (i.e. just an unique id, etc.). You can try contact form plugins like: or Formidable for now.


    ah ok, thanks. At least I’m not going crazy then.

    Thanks for looking into it. I have the form working by shortening the text. here:

    But as a suggestion, if Kriesi doesn’t end up changing the way he generates fields, then at least could you include a little “Use no more than X characters” in the theme setup section so it doesn’t break.

    But thanks again, appreciate it.


    Hi Tim,

    Glad you have it working now. I’ll suggest the text change to Kriesi for the documentation as well.



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Bug in Contact form’ is closed to new replies.