Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23891

    And again…

    Currently, any portfolio item won’t show up on my page leading to a 404. Portfolio Grids are fully functional – only the detail page of an entry won’t do it.

    After adding flush_rewrite_rules() to the theme pages and posts are working fine. Unfortunatley, the custom post type portfolio won’t make it.

    If I deactivate Enfold switching to twentytwelve, everything is fine. To test it with a CPT I created a simple one by myself.

    Also, I left the custom slug as is (portfolio) and changed only the language options (NL, EN) to portfolio-nl an portfolio-en. The slugs ain’t used in any other place (no page, no post, no tax, no tag, no cat).

    I’ve searched the whole support forums here and also found several threads to this issue on WPML support. None of the suggested solutions (and/or workarounds) are quite functional for me.

    WPML is configured to use the folder type (e. g. domain.com/en/) so I think this is maybe conflicting with the basic .htaccess rules.

    Do you have any tips or hints for me?

    Meanwhile I will investigate wp_options table on rewrite rules a dive a bit deeper into this… :-/

    Thanks…

    PS: Tried also /%category%/%postname%/ – but category won’t show up in permalink…

    #121517

    After some more investigation in this issues with 404 (and probably plugin errors, MCE non-functional) I suggest you to check your PHP memory_limit. Common settings for this value is only about 64M (even with professional hosting), which will be very fast consumed by the avia framework, layerslider and other components. If you use some more plugins which allocate unusual high memory, you will run out of (PHP) memory.

    To get Permalinks working, flush_rewrite_rules should be “true” (remove any lines you may have inserted) and after raising the memory allocated to PHP save your Permalink structure once. Everything should be okay.

    If you just like to check it, set WP_DEBUG to “true”, switch to your backend, edit a post or page an have a look at the very end of the page. If there’s an error present stating that memory allocation is exhausted, you have to increase the memory_limit.

    Thanks to Chris who finally found the error message… :)

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘[Bug] Portfolio item > Permalink renders to 404 page’ is closed to new replies.