Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15894

    Hi,

    not only in my theme, but also in the demo theme http://www.kriesi.at/themes/corona/portfolio-item/asdf/

    I’ve discovered obviously a bug:

    In theme options I have set at “Enter a page slug that should be used for your portfolio single items” my own: “portfoliomalerei” (in demo theme it is obviously set as “portfolio-item”).

    So far, so good, see it in action here in demo theme:

    http://www.kriesi.at/themes/corona/portfolio-item/asdf/

    Now take a look at the URL of this page in the browser:

    But now hover over Categories: CSS / Javascript / PSD” , the part below the big image, where the date of this entry is:

    and you see, that for these category slugs a complete other portfolio”slug” is used, in demo theme “portfolio_entries”.

    This causes, when a user clicks on this part Categories: CSS / Javascript / PSD” of such a portfolio entry, he goes to the “archive” page of this portfolio category.

    And now this archive page has – the wrong! – URL of http://www.kriesi.at/themes/corona/portfolio_entries/css/, although in theme settings, the portfolio slug is set as “portfolio-items“.

    In my own CORONA version it is exactly the same behaviour.

    So what can I do, that also these archive pages uses exactly that portfolio slug, too, that I have set in the theme options for portfolio pages?

    Because at the moment, I have set it in theme options -> Portfolio to “portfoliomalerei” and the archive pages for a portfolio category is “…/portfolio_entries/schwebende-bilder/”

    #89420

    Hi colorit2,

    As far as I know this is just how wordpress handles archives. That url is generated based on the taxonomy created by the theme when it creates the new portfolio item post type.

    I’m really not sure if and how it would be possible to change the rewrite rules for the portfolio custom post type when displaying archives. I’ll have to tag Kriesi on this to see if it something that can actually be changed and what the best avenue for it would be.

    Regards,

    Devin

    #89421

    yes, that would be great asking Kriesi; somewhere must be the “portfolio_entries” set. I’ll wait until what Kriesi says to it, thanks.

    #89422

    Hi!

    Keep a check on this thread.

    Best regards,

    Mya

    #89423

    Hey. actually not a bug but the way that wordpress handles custom post types.

    The slug you are setting in the backend is the slug for single portfolio items. The archive that is generated by wordpress is based on the post type and the coresponding categories. In this case portfolio_entries. Changing this slug name dynamically like the slug you mention is unfortunately not an option since it will invalidate all the existing categories of this post type which would seriously throw off users…

    Cheers!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘BUG: Portfolio page slug ignored on archive pages of portfolio items!’ is closed to new replies.