Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #23842

    I’d like to use a Guestbook pluggin (Comment Guestbook is the pluggin name). I’ve loaded it and the form seems to work, but no comments show up. I’ve made sure “Allow people to post comments on new articles” it turned on in Settings -> Discussion, but still no comments are showing up. I’ve also made sure the test comment I wrote was approved. I’m using the most recent version of Flashlight and WP.

    Is there a way to have comments show up on a page? And by “page” I mean a Page, not a Post.

    Thanks!

    #121331

    Hi,

    Edit page.php then find this code

    get_template_part( 'includes/loop', 'page' );

    Add this code below

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    Edit a page, look for Screen Options > Check the Discussion option.

    Regards,

    Ismael

    #121332

    Okay, added the code, but now a comment box is showing up on all my static pages. And I don’t see anywhere when editing a page where I can find “Screen Options” and check or uncheck a Discussion option. Can you tell me very specifically, where should I be able to find “Screen Options”?

    Thanks.

    #121333

    Found it! The answer would be “top right corner.” Thanks!

    #121334

    Hey,

    Glad it worked. :)

    Regards,

    Ismael

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Can you have comments show up on pages? (I mean Page, not a Post)’ is closed to new replies.