Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19070

    Hello,

    I have searched through all the options, but I cannot get the page title of my Home page to appear at the top of the browser…

    I’d like it to appear is Remco Press | Welcome

    But it shows up right now only as Remco Press |

    http://www.remcopress.com

    What am I missing?

    Thanks for a fantastic, responsive theme, this was so easy and fun to set up!

    Tony

    #102065

    Hi Tony,

    In the header.php file you’ll find this line:

    <!-- page title, displayed in your browser bar -->
    <title><?php bloginfo('name'); ?> | <?php is_home() ? bloginfo('description') : wp_title(''); ?></title>

    You can remove the is_home check so that the title is displayed instead of the blog description like so:

    <!-- page title, displayed in your browser bar -->
    <title><?php bloginfo('name'); ?> | <?php wp_title(''); ?></title>

    Regards,

    Devin

    #102066

    Hi Devin,

    Thanks for the fast response!

    I tried your suggestion, but it didn’t work. Oddly, I now have a blank space next to the | in my browser bar, as if the word “home” was there but in invisible ink!

    Is there a setting somewhere I am missing? I have tried disabling my SEO plugin, but it seems to make no difference…

    Thanks again for your help!

    Tony

    #102067

    Just took a look at the codex again and home pages set with custom loops (as yours and most are) don’t have any title capable of being set.

    You’ll need to undo the changes I suggested above and use the Tagline field for the home page title that you want in the WordPress options Settings>General.

    Reference: http://codex.wordpress.org/Function_Reference/wp_title#Covering_Homepage

    Regards,

    Devin

    #102068

    Still didn’t do the trick. I had the tagline set before I posted here, so I had a feeling it wasn’t that. Any other suggestions? Could it be in a template somewhere?

    #102069

    If you’ve undone the changes from before, the tagline should be showing up. There is nothing else that should interfere with it unless you have an SEO plugin installed or something like that which is supposed to replace it.

    #102070

    Hi Devin,

    I just fixed it! Or should I say, you fixed it…:)

    Your link was the key. I tried all the options in the WordPress Codex, and finally used the “hack,” and that did the trick.

    Thank you for such quick and helpful support!

    Tony

    #102071

    Glad we could help :)

    Regards,

    Devin

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Cannot get Home page title to appear at top of browser’ is closed to new replies.