Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26565

    Seems that I have some URLs that aren’t converting to HTTPS… like menu items… so although the SSL is working properly, it’s giving a…

    “Your connection to djdevelopment.net is encrypted with 256-bit encryption. However, this page includes other resources which are not secure. These resources can be viewed by others while in transit, and can be modified by an attacker to change the look of the page.”

    …message.

    For instance… even though I have it set to visibility:none this code still shows up in the source of the page…

    <div class=’footer_arrow’><div class=’inner_content’><div class=’arrow-left-small’></div><div class=’arrow-right-small’></div><h3>Need help? Email Us!</h3></div>

    I was thinking about changing the WordPress Address (URL) to include the HTTPS… but am leary of messing with this. It’s a huge site.

    Can you advise? Thanks !!

    #130855

    I managed to change the URL for the logo… it wasn’t changing itself… but these are listed too…

    [blocked] The page at https://djdevelopment.net/3/checkout/ ran insecure content from http://fonts.googleapis.com/css?family=Open+Sans:400,800,300,700.

    djdevelopment.net/:1

    The page at https://djdevelopment.net/3/checkout/ displayed insecure content from http://djdevelopment.net/3/wp-content/themes/replete/images/background-images/diagonal-thin-light.png.

    djdevelopment.net/:87

    The page at https://djdevelopment.net/3/checkout/ displayed insecure content from http://djdevelopment.net/3/wp-content/themes/replete/images/background-images/diagonal-thin-light.png.

    djdevelopment.net/:213

    The page at https://djdevelopment.net/3/checkout/ displayed insecure content from http://djdevelopment.net/3/wp-content/themes/replete/images/background-images/wool-for-light-background.png.

    So the Google font used, and the background files used… all designated within the Replete Theme Options are not changing. How do I fix this?

    I also have images that are being used in Revolution slider that aren’t changing. Your thoughts on these?…

    Thanks guys!!

    #130856

    Hi mgma,

    You can use a plugin like http://wordpress.org/plugins/force-ssl-everywhere/ which should change the urls where needed.

    Regards,

    Devin

    #130857

    Thanks Devin… but it changes everything… the homepage won’t even load. Other suggestions?

    TX

    #130858

    Then there is something else misconfigured. Either with the SSL certificate or with the the hosting settings for it.

    With WooCommerce itself, you can set the option to use SSL on the checkout pages and you can also change the root url of the site but you might to check with the hosting provider to make sure that everything is set to load through ssl like that.

    Also keep in mind that when you load all elements and all pages of a site via https it tends to slow things down just a bit. So typically, unless you have to keep all logins going through https sites just keep the cart and checkout pages using the ssl certificate.

    #130859

    I couldn’t be with the certificate though, if all other URLs are correctly changing… do you agree? Is there somewhere I can get at this URL for accessing the Google fonts in this template? So I can change it manually? I can’t find it anywhere. That, and the image URLs from Revolution slider are the only ones I’m stuck on.

    Thanks

    #130860

    If you are using the most recent version of the theme it should be set automatically. If not, you can manually set it in framework>php>class-style-generator.php.

    Look for something like:

    $this->extra_output .= '<link id="google_webfont_'.$this->webfont_count.'" rel="stylesheet" type="text/css" href="'.$prefix.'://fonts.googleapis.com/css?family='.str_replace(' ','+',$rule_split[0]).$font_weight.'" />';

    on line 194. the $prefix variable can be changed manually to just https all the time.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Can't get SSL to work with the theme….’ is closed to new replies.