Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #17169

    I have a travel blog and need to insert many vertical pictures like Pisa tower for example. But this template does not allow me to do so!

    Is there a way I can do it? Picture’s settings are ok, but if I insert a vertical picture, the template keeps cutting it’s up and lower ends, and the photo makes no sense! Please, help me!

    #94425

    Hi celmartin,

    At what point is the image getting cropped? The theme will automatically crop images to be used for thumbnails or slideshow images if it goes beyond the settings (so that it doesn’t mess with the overall visuals).

    Usually, if you want to add a full size image it would go into the body of the post or page so that you can control the size and layout in the visual editor.

    If you have a link to the page and can point it out we can provide some additional steps to take. If you want to just force the theme to not crop at all, you can edit the functions.php of your theme files so that the specific image type gets forced not to crop. For example, you can force the related image thumbnails not to crop by changing that line to:

    $avia_config['imgSize']['related'] = array('width'=>130, 'height'=>95, 'crop'=>false ); // small images for related items

    Just make sure you add:

    , 'crop'=>false

    including the starting comma .

    Regards,

    Devin

    #94426

    Thanks Devin, for you reply.

    I don’t have any problems with thumbnails.

    But my problem is exactly in the posts! Here is a link of a post in witch I’ve tried to put a vertical image: http://www.maladerodinhaenecessaire.com/guest-post-ground-zero-por-patricia-blower/

    As you can see, the vertical image’ s top and button are cut off. Only by clicking on it you can see the “real image” that I insert in another page and out of the post itself. And I really need to insert vertical images of many places I’ve visited.

    #94427

    Oh I see, in that case it isn’t anything the theme is doing but instead the settings you choose from the wordpress options when you insert an image.

    Try selecting the image in your visual editor and then clicking on the image icon that should appear while your mouse is still on the image. In the box that pops up, select the option for “Full Size” under the Size heading.

    Regards,

    Devin

    #94428

    Hi Devin, I get the same error! Inside a post, when I insert an image, the theme or wordpress crop the image to 250px height, and I select FULL SIZE…

    You can see a sceenshot here: http://www.topimatge.com/temp/crop.jpg

    Thanks,

    Marc

    #94429

    Hi,

    Please install the plugin (simple image sizes – http://wordpress.org/extend/plugins/simple-image-sizes/ ). The plugin will display additional image size fields inside the Settings > Media admin folder. Please change the setting that is set to 250 and turn off the crop (option will be available with the plugin. Images work very specifically with wordpress . You have to set sizes for specific locations that image may be placed in, so as soon as your image is uploaded it is cut into different sizes because WordPress doesn’t know where you will use it , so it makes 9 images and crops them or cuts them or just proportionally shrinks them depending on the settings for each image. location.

    I suggest you experiment, and use a new image with each test because changing sizes in the backend only affects future images .

    Thanks,

    Nick

    #94430

    Thanks Nick, I’ve installed this plugin and I could change the height and works perfectly.

    Thanks!

    Narc

    #94431

    Hi Narc,

    Glad that Nick helped you. :)

    Cheers,

    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Can't insert a vertical picture’ is closed to new replies.