Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #21662

    I saw a note about creating a slideshow & blog on the same page, so I followed the instructions & the page looks great. I created a dynamic template with both elements, uploaded the slides & made sure not to assign the page as a blog. However, when I select this page to display on the Frontpage, only the blog displays???

    In case this is coded to the frontpage template, I also added a blog to that & set up the slideshow entry point; I then assigned the frontpage template to the page. As it still didn’t work, I reverted back to the original state.

    How does this theme permit a slideshow & blog on the “Frontpage”?

    #112620

    Hi,

    Here is a screencast video I made showing the process. It works fine. https://docs.google.com/file/d/0B8hqGBMSfHtKOHlMM3kzVW4wQk0/edit?usp=sharing

    Thanks,

    Nick

    #112621

    Hi Nick,

    I’ve watched your video twice, but I can’t see anything that might be missing. Furthermore, when I click “View Page” from the page editor, it works & I can see my slideshow with blog; however, as soon as I click on “Home” only the blog displays.

    Note that my posts are uncategorized, and although I have this blog ‘section’ on my frontpage, I do not have a separate blog page – I left that Propulsion option blank (though I tried that too).

    It’s as though something is overriding it. I even tried renaming the page to “Home”.

    Salim

    #112622

    Hello,

    Further to my response above, I believe that I have solved the problem. I could perhaps have changed this topic to:

    Slideshow does not display on “Frontpage” or Homepage.

    When I deleted the blog element, the slideshow still didn’t show so that I was left with just my menu.

    So, my question became why does my slider appear on any page with a slideshow element EXCEPT the Frontpage or Homepage?

    The solution was to change the Slideshow Size option to “Adjustable Slider” instead of full width. It now shows with the blog at http://eqhow.com/ Kindly let me know if you have any comments on my Propulsion option settings from my previous response.

    Best regards,

    Salim

    #112623

    Hey!

    Glad that you solved the problem :)

    Best regards,

    Peter

    #112624

    Hi,

    Glad you figured it out. You can define a blog page as your front page so that both the blog and homepage select boxes in Propulsion > Theme Options are pointing to your home page. Is your homepage correctly set in the Menu? does it have the word Custom as the type of menu button and show up as in the browser as your-domain.com and not as your-domain.com/home/ or something? I think uncategorized is a bad way to do it from an seo perspective though i can’t seem to think of how that can adversely affect anything else,uncategorized is in reality categoryID = 1.

    Thanks,

    Nick

    #112625

    Hi Nick,

    Thanks for your SEO tip: I will plan to use categories soon. The homepage does appear to be correctly set in the Menu and also shows up in my browser as my-domain.com, though I don’t know where to check the Menu button type as Custom – I glanced at my Menu settings.

    Thanks,

    Salim

    #112626

    Hi,

    Please look here http://www.clipular.com/c?4031042=oeIZ7wQ5FSpCBMhq1ptZwEflkRg&f=.png

    You see Pages, and List all. And one option says Home:Home. That is the correct home. Because the real home is Cart page below it , since I designated it as the home , but if placed in the menu, the link will not look correct. So if you call a page My Home , that is how it will be listed here, though the Home:Home custom link will still be here and be the correct choice.

    Do you see the word ”custom” by the way on the Home item in the above image?

    Nick

    #112627

    Thanks again Nick,

    On that page, here is what I had:

    Home: Home

    Emotional Intelligence assessments

    Executive Coaching

    Home

    Leadership Coaching

    My “home” did not have the word custom as the type of menu button, & I also noticed on my site that the Home link showed as http://eqhow.com/?page_id=231

    Kindly confirm if the following is correct: I deleted the named “Home” menu & replaced it with the “Home: Home” menu. Like your image, it now shows as type “custom”, and it also shows up correctly in the browser as eqhow.com

    Cheers,

    Salim

    #112628

    Hi,

    Looks good. Any reason why you are using URLs like that with query strings instead of the more seo and visitor friendly permalinks? Settings > Permalinks in wordpress admin. You should use one of the custom formats instead.

    Thanks,

    Nick

    #112629

    Hi Nick,

    I changed the permalink setting to “Post name”, pages such as Executive Coaching changed from http://eqhow.com/?page_id=150 to http://eqhow.com/executive-coaching/ However, when I click on the Recent Post links from the right menu or search site, I get an error 404? And how is it different from the custom structure which has %postname%.

    Thanks,

    Salim

    #112630

    Hi,

    Please check your .htaccess file that it has correct rewrite rules. Also for whatever reason, the longer the permalinks arent set , the higher the chance of getting these types of errors. You can install these plugins, the first will allow you to see what’s in your htaccess file, and the second will let you check if you are missing any rewrite rules.

    http://wordpress.org/extend/plugins/wp-htaccess-control/

    http://wordpress.org/extend/plugins/rewrite-rules-inspector/ (look in tools > rewrite rules after setup, if any in red)

    Thanks,

    Nick

    #112631

    Thanks Nick,

    You’re right. When I deleted & recreated my first blog post, it works fine now.

    Best regards,

    Salim

    #112632

    Good luck Salim.

    Thanks,

    Nick

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Can't show slideshow with blog on "Frontpage"’ is closed to new replies.