Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2540

    Hi. I’ve added several child category pages and then, in the Options>Sidebar & Footer menu, added “extra widget areas for specific categories.” I also selected Yes for “display widget areas for categories on posts as well” for those categories.

    Then I went into my widgets and tried to add several items but none shows up. The widgetized areas are there (albeit they all say sidebar left while the sidebar is on the right, but that doesn’t appear to make any difference elsewhere). But when I add anything to them…nothing is there.

    Do these not work on child categories for some reason? I can’t imagine why that would be…

    Thoughts? The site is under construction at http://www.learnitsystems.com/new.

    #38376

    Hey,

    Sent you an email…

    James

    #38377

    Hi, i have the same problem. Could you help me?

    Thanks a lot.

    #38378

    Hey,

    I’ve spend a fair bit of time looking into this, creating categories / sub categories and trying out different options.

    I agree it definitely a bug with sub categories, further research needs to be done to figure out exactly what’s going on.

    It’s far from ideal, but a quick fix is to add the widget to appear everywhere and use the Widget Logic plugin to restrict its display to only the categories you want to have the widgets show up on. If you need help getting this setup, let me know.

    James

    #38379

    I have used widget logic before and do know how to do that; was just hoping it was something simple I was doing wrong. Please let me know if you ever get it fixed. Thanks for taking so much time on it.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Can't successfully widgetize child category pages.’ is closed to new replies.