Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #298152

    Hi there,

    I want to change the dropdown menu in the header of the background color. From now white on black and on mouseover # 333333 The font must then be white.

    Thanks for your help
    Andrej

    #298582

    Hey Andrej!

    Try adding this code to the Quick CSS:

    .sub-menu > li:hover > a {
        background: red !important;
    }

    Cheers! 
    Josue

    #298640

    Hello Jose,

    Thank you for your help. But unfortunately it does not work. Here’s the page: http://www.andriy.de Menu> Services

    Best Regards
    Andrej

    #298684

    Works here. Use F5 to refresh the page!

    #298696

    Thank you, you have helped me a lot. My final code looks like this:

    .sub-menu > li > a {
    	color: #b2b2b2 !important;
    	background: #000000 !important;
    	border: #333333 !important;
    }
    .sub-menu > li:hover > a {
        color: #ffffff !important;
    	font-weight: bold !important;
    	background: #333333 !important;
    	border: #333333 !important;
    }
    

    Best Regards
    Andrej

    #298699

    Hey!

    The code Josue posted seems to be working fine on my end as well – http://i.imgur.com/uB9rFVi.png
    Please flush browser cache and refresh your page a few times

    Regards,
    Yigit

    #715718

    Hi Yigit
    I’m also trying to get the dropdown menu color to be different from the logo area background color. I’ve tried this:
    .sub-menu > li:hover > a {
    color: #ffffff !important;
    font-weight: bold !important;
    background: #752e7b !important;
    border: #752e7b !important;
    }

    But that doesn’t work.
    I’m also trying to get the menu item text to appear in the middle (vertical), but I can only achieve that by adding a css line height instruction which doesn’t look good when the screen gets smaller. Hope you can help.

    Regards – Raphe

    #715927

    Hi,

    Please go to Enfold theme options > Advanced Styling and edit “Main Menu sublevel Links”. Make sure to check “Apply only to mouse hover state” for hover state.

    Please try adding this code to the Quick CSS section under Enfold > General Styling or to your child themes style.css file:

    .html_header_top .av_bottom_nav_header .main_menu ul:first-child > li a {
        height: 80px;
        line-height: 80px;
    }

    Please make sure that > sign is not converted to – http://i.imgur.com/IDXRZQ3.png in Quick CSS field. I previewed the code on your site and it does look totally fine on smaller screens on my end.

    If you still have issues with the code, please start a new thread under Enfold sub forum and attach temporary admin logins in private content field. If you post them here, they will be visible to creator of this thread as well.

    Best regards,
    Yigit

    #716256

    Thanks v much – excellent support as usual.
    Raphe

    #716331

    Hi Raphe,

    Glad we could help :-)

    Please let us know if you should need any further help on the topic.

    Best regards,
    Rikard

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.