Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2657

    Hi, I’m new to working with WordPress. I’m using your excellent Newscast theme. Specifically “Newscast – Light,” a.k.a. “Skin1.”

    I’d like to change the default text in the logo to the name of my website and add my tagline.

    I found the “logo.png” file in the “Skin1″ folder and opened the logo file with GIMP.

    However, I didn’t see separate layers. I was looking for a “text” layer so I could edit the logo text to the name of my website and add my own tagline.

    I checked in every GIMP menu for an “ungroup layers” command or something similar, but I couldn’t find one. Could you please advise? I tried searching through the forum first, but if this issue has already been addressed I must have missed the thread.

    I apologize for the inconvenience. Thank you for your help.

    #38822

    Hey,

    you can find the layered image files (psd files) in the themeforest zip package. It includes the documentation, psd (layered images) and the theme files. Just open the layered photoshop files with Gimp or Adibe Photoshop and change the logo as you like :)

    #38823

    Hi, thanks for your quick reply, and on New Year’s Day! I was willing to wait until Monday or Tuesday for answer.

    With you guidance, I found the PSD file and the text layer! In GIMP, I can’t seem to edit the text, though. Whenever I select the text layer and text tool then click on the “Newscast” text, it opens a new text box. I want to open the existing text box so I can change the words.

    I tried clicking on the text layer and the text itself, but those didn’t work. I tried right-clicking too. Didn’t work either. Please advise. Sorry, I’m sure this task is super-simple for a professional like you. I’m a total newcomer to this stuff. I appreciate your help.

    #38824

    Hey,

    I need to request the psds first. I’ll help you asap.

    #38825

    Hi, thank you for your fast response. I tried to use the contact form on your website (http://peter.schoenmann.at/kontaktformular. However, I got an error message.

    Do you have another e-mail address? I can attach the PSD files and send them to you. Good thinking, changing the text of the logos for all 4 skins. Convenient in case I change skins in the future.

    I do not want to write my e-mail on a public forum. You can use the contact form on my travel blog: http://www.marcusgoesglobal.com/p/contact.html. Send me a message, and I will get your e-mail address. Please write “Change Newscast Logo” in the subject line. Then I will send you the PSD files.

    Hope this works. Thanks.

    #38826

    Hey,

    I requested the psds from Kriesi two hours ago. I think he will answer shortly :). I don’t know why my contact form didn’t work for you – maybe you forgot to fill in a mandatory field (fields which are marked with “(Pflichtfeld)” – Email, Name and Message )

    #38827

    Ah, that was a better idea, requesting the PSDs from Kriesi directly. I must have left a field empty on your contact form. I actually tried first filling out your contact form in Google Translate, because I cannot read German. Then I tried the second time on your website directly.

    Here’s what I’d like you to change the default text to:

    Linux for Artists

    Use free software to unleash creativity

    Thanks for your patience.

    #38828

    Hey,

    I uploaded the modified version here: http://www.mediafire.com/?ymq0rzox66e8j0j

    #38829

    Thanks, I was able to download the image. I had to export the PSD file as a JPEG file to upload it to the WordPress media library.

    I went to “Newscast General Options,” and tried to use the “Logo” box to insert the logo image. Insert Image > Media Library > clicked on “Show” next to the logo.

    I clicked “insert into post.” The insert image box then just goes blank white. I tried again and clicked “use as featured image” instead. My logo still did not show up on the website.

    Did I miss a step somewhere? Or is there another way to insert the logo into the theme?

    Also, I noticed that the “Linux for Artists” text is black, not the same silver color as the tagline. Very hard to read black text on a dark gray background in the header. I want all the text to have the same nice silver color.

    Sorry I keep having trouble. Please advise.

    #38830

    Which skin are you using? Maybe I used the wrong logo. I’ll export the image to png – maybe gimp can’t handle the effects because my source file looks fine here (I’m using Adobe PS).

    To use the modified logo just upload it with filezilla to wp-content/themes/newscast/images/skin folder (number depends on the skin you’re using)

    #38831

    I was using “Skin 1,” the “Newscast – Light” skin. I was able to upload the logo with Filezilla to my site. But I couldn’t find the logo in my WP files afterwards from the WP dashboard.

    But yeah, in the live preview of “Newscast,” all the letters are silver, not just the tagline. Yes, please export the logo image as a png and I’ll try again. Thanks!

    #38832

    Hey,

    I uploaded the exported png here: http://www.mediafire.com/?49q55f3l2516k6m

    WP won’t show you the logo because the theme editor just shows (certain) php and css files. I strongly recommend to edit all files offline by using a “professional” text editor (notepad ++, etc.)

    #38833

    The logo looks great!

    I finally figured out how to get my logo onto my website. I’m embarrassed to explain my mistake, since it’s so absurdly simple.

    For the benefit of anyone reading this, here’s what I did:

    WordPress Dashboard > Newscast Theme Options > “Newcast General Options”

    Look for the logo box. Click on “Insert Image.” Choose an image file from your computer.

    Click on “Insert Image.”

    Click on “Media” on the left-hand side of the dashboard.

    Click on your image you just uploaded.

    Scroll down to “File URL.”

    Copy the URL in that box.

    Go back to “Newcast Options.”

    In the logo box, paste that URL. DO NOT click “Insert Image” again. That’s the mistake I made.

    Scroll down to the bottom of the page. Click on “Save Changes.”

    Now you should be able to see your logo. This worked for me.

    I can’t believe I forgot to click “Save Changes.” I think because that button is “below the fold” on my screen and I didn’t see it until I scrolled down.

    Maybe the Dude can correct me if I missed anything. Thank you for your patience and help!

    #38834

    No, your tutorial is perfect :)

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Change logo text from "Newscast" to name of my website?’ is closed to new replies.