Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #14812

    Hello Team!

    I have been trying to figure out for days, how to change the width of the portfolio image on the portfolio entry in your theme Choices. My pictures will be all different sizes, and I have standing and lying types of pictures as well. There is nothing wrong with the lying ones, but once I upload a standing one, the image is way too long on the portfolio entry. I want to reduce the width of the image right next to the portfolio meta info.

    I hope I was clear enough, I am very new at WordPress.

    Thank you for your support,

    Viktoria

    #84969

    Hello,

    Can you post a link on your website?

    If you want to adjust the image sizes for your portfolio entries, please open functions.php and find this code

    $avia_config['imgSize']['fullsize'] = array('width'=>930, 'height'=>930, 'crop'=>false); // big images for lightbox and portfolio single entries

    Adjust the width and height then regenerate or re upload the images.

    Regards,

    Ismael

    #84970

    Hi Ismael,

    I already tried the option that you posted, it didn’t work, but I gave another try.

    Now I have this:

    $avia_config = array(‘width’=>120, ‘height’=>930, ‘crop’=>false); // big images for lightbox and portfolio single entries

    Unfortunately it is still not working, it breaks up the image while the width doesn’t change. (The original image size: 542×1000)

    Here is a link: http://www.theartsofsilence.com/portfolio/test1/#!prettyPhoto

    I just noticed, that since I updated Safari, the magnifying glass is gone in Lightbox. It is working fine in Google Chrome…

    Thanks!

    Viktoria

    #84971

    Hi Viktoria,

    I see what you mean now. You’ll also need to change the slideshow from automatically scaling the image to fit the container. This may make the site not as responsive for mobiles and such, but otherwise you’ll need to do some heavy editing of the theme files.

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.single-portfolio .slideshow li img {
    width: auto;
    }

    Regards,

    Devin

    #84972

    Hi Devin,

    1.) I set the default image sizes, and added the code that you suggested. The size is better, however I think it is blurry. http://www.theartsofsilence.com/portfolio/test1/#!prettyPhoto

    Anyway, how can I adjust the grey lightbox overlay? (It is wider than the image)

    2.) Do you have any other idea for my original question? Is there any chance that I can adjust the proportion of the image and the metainfo? (it seems that there is about 66% width for the image and 33% for the metainfo)

    3.) The magnifying glass is back :)

    Thank you again,

    Viktoria

    #84973

    The reason why the image is blurry and the overlay doesn’t fit is following rule in css/custom.css:

    #top.single-portfolio .slideshow li img {
    width: 75%;
    }

    if you change it to:

    #top.single-portfolio .slideshow li img {
    width: 100%;
    }

    or if you remove it the issue will be solved.

    #84974

    Dude, would you please read my original question? This problem that you just answered was an additional one.

    So how can I change the image width AND the adjust to magnifying glass to it in the single portfolio entry?

    This code would work for me,

    #top.single-portfolio .slideshow li img {

    width: 75%;

    }

    but I need to change the size of the mag.glass, and I don’t know where I can find the code.

    Please help, thank you very much!

    Viktoria

    #84975

    Hello,

    You can adjust the magnifying glass overlay effect with this.

    .image_overlay_effect_inside.da-animate.da-slideFromBottom {
    width: 70%;
    height: 70%;
    }

    Regards,

    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Changing image width in the portfolio entry’ is closed to new replies.