Viewing 30 posts - 1 through 30 (of 33 total)
  • Author
    Posts
  • #14067

    I’d like to modify the size,(or more precisely the cropping), of the images displayed in the slideshow of the product pages. (This type of page: http://www.kriesi.at/themes/propulsion/shop/test-product-with-small-image/)

    What happens is that if I upload an image in portrait format, it will be cropped. How can I adjust the default format of the slideshow to one particular image size?

    #81938

    The image/slideshow size (single shop page) is defined in propulsionconfig-woocommerceconfig.php – adjust the height value and regenerate the thumbnails with: http://wordpress.org/extend/plugins/regenerate-thumbnails/

    $avia_config['imgSize']['shop_single'] 		= array('width'=>450, 'height'=>355);

    #81939

    Thanks! So I did just that, but it doesn’t seem to modify the size of the pictures in the slideshow…

    #81940

    Hey!

    Maybe you need to configure the image size via WooCommerce – go to WooCommerce > Settings > Catalog and scroll down to the “Image Options” section to change the thumbnail size.

    Best regards,

    Peter

    #81941

    So I tried redoing it all, but no luck. I managed to change the format/ratio of the pictures on the homepage and of the thumbnails on the product page, but this won’t work for the bigger pic over the thumbnails on the product page.

    :(

    #81942

    Hey,

    On the link provided, there is no slideshow. Are you referring to the lightbox preview?

    Regards,

    Ismael

    #81943

    I think that’s it, yes. The picture on the left.

    #81944

    Hello,

    Go to js > prettyPhoto > js > jquery.prettyPhoto.js and find this code.

    (function($){$.prettyPhoto={version:'3.1.3'};$.fn.prettyPhoto=function(pp_settings){pp_settings=jQuery.extend({animation_speed:'fast',slideshow:5000,autoplay_slideshow:false,opacity:0.80,show_title:true,allow_resize:true,default_width:500,default_height:344,counter_separator_label:'/',theme:'pp_default',horizontal_padding:20,hideflash:false,wmode:'opaque',autoplay:true,modal:false,deeplinking:true,overlay_gallery:true,keyboard_shortcuts:true,changepicturecallback:function(){},callback:function(){},ie6_fallback:true,markup:'<div class="pp_pic_holder">

    You can choose not to resize the images by changing this line of code to false.

    allow_resize:true

    Or you set the default width and height of the images on lightbox with this code.

    default_width:500,default_height:344

    If you mean to change the thumbnail. I think Dude’s solution is the way to go. You just need to regenerate the thumbnails. Remove cache then reload the page.

    Regards,

    Ismael

    #81945

    I’m having problems with the bigger pic over the thumbnails on the product page (not the light box).

    Images are cropped but they are originally uploaded as 600×600 and set in Woo as 450×450 for product page, and I tweaked config-woocommerce/config.php to set images at 450×450.

    Pls help.

    #81946

    Use this page as example of what’s happening:

    http://beastsyndicate.com/streetwear/shop/big-in-japan-t-shirt/

    #81947

    Hi,

    You are cropping them now at 450 x 335.

    To quote Dude:

    “The image/slideshow size (single shop page) is defined in propulsionconfig-woocommerceconfig.php – adjust the height value and regenerate the thumbnails with: http://wordpress.org/extend/plugins/regenerate-thumbnails/

    $avia_config['imgSize']['shop_single'] 		= array('width'=>450, 'height'=>450);

    Thanks,

    Nick

    #81948

    Nick,

    How do you know I’m cropping images at 450 x 335?

    I had already set up propulsionconfig-woocommerceconfig.php as below and reconfig’d thumbnails:

    product thumbnails

    $avia_config = array(‘width’=>80, ‘height’=>80);

    $avia_config = array(‘width’=>450, ‘height’=>450);

    $avia_config = array(‘width’=>450, ‘height’=>450);

    Am I missing something? / Can you double check my code?

    #81949

    Meant to say I redid thumbnails again this AM but still having cropped images….

    #81950

    Hi ATX,

    Try to change:

    $avia_config['imgSize']['shop_catalog'] = array('width'=>450, 'height'=>450);

    to

    $avia_config['imgSize']['shop_catalog'] = array('width'=>450, 'height'=>450, 'crop'=>false);

    Regenerate the images and clear the browser cache and try to check it again.

    Regards,

    Ismael

    #81951

    Added suggested code, regenerated the images for 2 page (below) and cleared cache but still had problems/no change.

    I even added ‘crop’=>false to ‘shop_single’ but still no change.

    Pls help.

    http://beastsyndicate.com/streetwear/shop/big-in-japan-t-shirt/

    http://beastsyndicate.com/streetwear/shop/222/

    #81952

    Hi ATX,

    This is the image being used for that page: http://beastsyndicate.com/streetwear/wp-content/uploads/2012/11/big_blk_on_silver600-450×335.jpg

    As you can see it has been generated to be cropped at 335 pixels tall. One of the settings either in woocommerce>config.php, functions.php or in the WooCommerce image settings should have this size. That is where it needs to be changed.

    Otherwise, please try regenerating ALL images for your entire site so that any function up until now gets properly generated.

    I also noticed you have an error showing up with the themes woocommerce-mod.js file, please re-upload it via ftp just in case the error causes any normal functions to not work correctly. This is inside the config-woocommerce folder within your theme files.

    Regards,

    Devin

    #81953

    Devin, super appreciate all the help from you and the team!

    With regard to the images, when I hover over the product image on the product page it tells me the file is the correct one (EG: big_blk_on_red600.jpg) and indeed they all look fine in light box.

    I checked woocommerce>config.php, functions.php and the WooCommerce image settings but all seem set up correctly. I really don’t know what to do – can you see these files etc are correct in case I’m not where I need to be?

    Would you mind checking that the js file is not corrupt – I just uploaded it again.

    Also, just so understand, why doesn’t _silver600-450×335.jpg doesn’t show up in my media file library?

    NOTE: I am having problems batch regenerating images (see my post here: http://www.kriesi.at/support/topic/error-regenerating-images?replies=1#post-83884)

    #81954

    Hi,

    If you have problems with batch, check what your host is allocating for you memory wise. This plugin http://wordpress.org/extend/plugins/wp-system-health/ is old and hard to find (search for keyword health), and it has a memory test, where it adds 1meg in usage one at a time until wordpress can’t handle it, because some hosts say one number but the plugin shows a much lower number.

    Simple Image Sizes plugin ( http://wordpress.org/extend/plugins/simple-image-sizes/ ). The plugin will give you complete control over all images in the theme -from aspect ratio, to width, whether to crop the image, and even has a built in thumbnail re-generator.

    After installing the plugin, you will find your Settings > Media page in the back-end to contain the various sizes. Then simply find the dimensions you want to change. Save. Regenerate the images and see if you like what you see or want to tweak the image sizes further.

    Thanks,

    Nick

    #81955

    Nick, I like the plugin – thx. And update my settings with my host server really helped with regenerating images.

    Installed, changed settings in plugin and regenerated images but still no change (even when clearing my cache in Fireforx). I checked Woo settings etc too.

    Is it not something in the template since it seems to effect all main product images?

    Pls help. Had hoped to launch e-store this weekend.

    PS; I don’t understand where Devin found this image/link (or how these images exist since not in media library):

    http://beastsyndicate.com/streetwear/wp-content/uploads/2012/11/big_blk_on_silver600-450×335.jpg

    #81956

    Hey!

    Did you check the WooCommerce thumbnail settings (WooCommerce > Settings > Catalog and scroll to the bottom)?

    Best regards,

    Peter

    #81957

    yes : (

    Really not sure what’s going on.

    Are there examples of people using this theme where the product photo isn’t cropped?

    #81958

    Is it possible to set up a temporary admin account for you to log in and see whats going on?

    I’m reasonably savvy so I feel I’ve made all settings etc as you recommended.

    But maybe I’ve missed something? Def. confused why images are not working.

    #81959

    Hi,

    I will take a look. Please email a temp admin account and ftp info. usjahm aaattt gmail dddooottt com

    Thanks,

    Nick

    #81960

    Thx Nick, just set it up for you.

    Appreciate you taking the time to check into it – you guys are phenomenal!

    #81961

    Hi,

    You have 2 errors showing up in WooCommerce :

    1) WP Memory Limit 32MB – We recommend setting memory to at least 64MB. See: Increasing memory allocated to PHP

    2) PHP Sessions – Session save path does not exist – contact your host to resolve the problem.


    OK, I got it to accept images and resize them to 450×450, http://beastsyndicate.com/streetwear/product/big-in-japan-t-shirt/

    Please keep your plugins up to date. Also remove plugins you are not using WP e-Commerce … since just because they aren’t activated doesn’t mean that they are ignored.

    **please don’t forget to delete the temp account you made**

    Overall though you have a pretty fast admin area, almost feels like you are running on Nginx and not Apache.

    Thanks,

    Nick

    #81965

    Thx Nick. That’s a HUGE help.

    I need to resolve 1 and 2, but what about other images (I see you got big_in_japan but not others – will this be fixed with regenerating images?)

    Out of interest how/where/what did you do to get b_i_j to work?

    Thx again man.

    #81966

    Hi,

    You need to go… here easier to show a video: https://docs.google.com/open?id=0B8hqGBMSfHtKOWF4ZEQxcm8wNVE

    Do the same thing for all the products. If you see any settings for the radio buttons (size different then what i show in video) switch it to the settings you see in video 450×450 , the very bottom one. This will work if all your images are proportional h=w (a square) , i have set the single product image at 450×450 crop.

    After you do what is shown on video for all items, don’t forget to save (do not insert since they are already inserted). After you save, regenerate the images and everything will be fine. When you upload you will also see multiple size options, so make sure you select the single product image.

    The one white shirt with godzilla was tough, i had to remove it from the page and add it again, it would not regenerate no matter what, while it seems everything else listened.

    Thanks,

    Nick

    #81967

    Nick,

    I was able to get my host to create a PHP Session save path and memory_limit is set to 96M (see: http://beastsyndicate.com/info.php)

    However, Woo System Status still says I’m at 32M.

    I am confused about changing memory limits, even after reading WP instructions.

    I didn’t understand where to add: define(‘WP_MEMORY_LIMIT’, ’96M’);

    I just emailed you info to log in as FTP user. Could you have a look and edit files as needed?

    Super appreciate your help with this.

    JT

    #81968

    Nick,

    Do I need to change memory limits before doing what you suggest in the video?

    #81969

    You need to insert the define(‘WP_MEMORY_LIMIT’, ’96M’); in wp-config.php (use a ftp software like Filezilla to access your server directories and wp-config.php can be found in the main directory where wp-content, wp-admin, etc. is located). Insert the line after i.e. following line:

    define('WPLANG', '');

Viewing 30 posts - 1 through 30 (of 33 total)

The topic ‘Changing size/cropping of the slideshow images in Product pages’ is closed to new replies.