Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20983

    hi kriesi,

    it seems that coherence together with WPML 2.7.1 is pretty slow. the backend works really slow, and in the frontend the portfolio http://montanara-ramsau.at/ferienwohnung/ is also not working well. please check http://www.montanara-ramsau.at – thanks

    #109906

    Hi xxtita,

    Can you point out some specific examples of items working incorrectly or not slow. I’m not getting any visual errors when I view the site and it seems to be fairly responsive to page navigation and loading content (nothing I would call slow).

    Regards,

    Devin

    #109907

    hi Devin,

    Frontend is ok, ecxept the portfolio, which is very slow to e.g. other sites with coherence and without WPML http://montanara-ramsau.at/ferienwohnung/

    But really slow is the backend. Can i send you PM with access to the site?

    #109908

    I’ve actually been hearing from a lot of people about somewhat slower backends with wordpress since 3.5.1. It could be a coincidence but it has been something I’ve now heard from sources outside of here as well.

    Typically, backend slowness is because of low memory availability. Here is a good guide on increase the memory available for wordpress to use: http://www.dailyblogging.org/wordpress/increase-wordpress-memory-limit/

    Regards,

    Devin

    #109909

    WP 3.4.2, plugins now only WPML and WP-Optimize, mem-limit pushed up to 128MB,

    backend ist now way better, still slow.

    frontend, portfolio site comes up fast, but when you click on a greyscale it lasts too long to open.

    I could live with it, but i want to make some other websites also with coherence and WPML, and i cant do that, if its not getting better, or faster.

    any ideas left?

    thanks in advance.

    #109910

    Hi,

    Hate to use a cliche but if you start fresh you will notice it will be a lot faster. I tested Coherence and WPML a week ago and it performed well. Did you notice at what point things began slowing down?

    Thanks,

    NIck

    #109911

    Hi Nick,

    as i told, now with WPML 2.7.1 the backend in much faster than it was. Still slow, but ok. What i worry most about is the portfolio site. http://montanara-ramsau.at/ferienwohnung/

    When you click on the grayscale pics, it lasts 8000ms to open the portfolio. Other sites without WPML open the portfolio in 2000ms. Please click on the above mentioned portfolio to see what i mean. thanks.

    #109912

    I’m getting a huge delay as well when trying to pull up an ajax portfolio item on the homepage. I’m not sure what the cause is here though but you could try creating a very basic portfolio item with just a single small image in it to get a comparison and see if it could be because of the size of the images in that portfolio item or if its something else.

    Regards,

    Devin

    #109913

    Hi,

    You are also loading a 1.5meg sized image on the page, which is your #1 problem, and takes 90% of the load time ( http://montanara-ramsau.at/wp-content/uploads/2012/10/oBERTAUERN-2009-rAFFALT_138.jpg ) .. Please optimize this image

    http://www.webpagetest.org/result/130313_HB_0d2172c87e07df19d6d87c458d53eaaa/1/details/

    Also if you notice there are those 4-5 images for the main slider that look like can also use a bit of optimization. Try using this without resizer http://jpeg-optimizer.com/

    Everything else as you can see by the link looks very tight, fast loading.

    Thanks,

    Nick

    #109914

    Hi Nick,

    A lot of pics are now optimized. The portfolio-site still opens after click on the grayscale to slow.

    Here is the result of the webpagetest http://www.webpagetest.org/result/130319_WB_TJ7/

    Maybe it would get faster, if i can force the cache options for the provided images? could this be an idea? if yes, do you know how?

    thanks,

    tita

    #109915

    Hi,

    Right now you got 3 issues you have to deal with to go to the next level of speed, even though you did a fine job of taking out 10 full seconds.

    I think the greyscales can be sped up. You are displaying the same color thumbnails and greyscale thumbnails but from two different urls. This causes each to load twice , but if you were using the same images that wouldn’t be happening.

    http://montanara-ramsau.at/wp-content/uploads/2012/11/app1_061-448x330.jpg
    and
    http://montanara-ramsau.at/wp-content/uploads/2012/11/app1_06-448x330.jpg


    http://montanara-ramsau.at/wp-content/uploads/2012/11/zimmer21-448x330.jpg
    and
    http://montanara-ramsau.at/wp-content/uploads/2012/11/zimmer2-448x330.jpg


    http://montanara-ramsau.at/wp-content/uploads/2012/11/zimmer21-448x330-greyscale.jpg
    and
    http://montanara-ramsau.at/wp-content/uploads/2012/11/zimmer2-448x330-greyscale.jpg


    http://montanara-ramsau.at/wp-content/uploads/2012/11/app1_061-448x330-greyscale.jpg
    and
    http://montanara-ramsau.at/wp-content/uploads/2012/11/app1_06-448x330-greyscale.jpg

    *) Time to first byte is waaayyy too long and shows an improperly configured Apache. It should be around a quarter of a second maximum, and not over 1 second. (This will be tough and perhaps should be left for last).

    *) None of your images have an expiration. We can fix that right up with htaccess

    Open up your .htaccess file (make sure you have ftp access to the website first in case a mistake is made). I am not sure what is inside your .htaccess file , but you will need to add all of this: https://github.com/h5bp/html5-boilerplate/blob/master/.htaccess

    The real part of that file you need are lines 1 – 280 ; . Just make sure they come before the normal 8-12 lines that WordPress adds to the htaccess.

    Thanks,

    Nick

    #109916

    Hi Nick,

    with the .htaccess file now the performance is perfect.

    thanx

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Coherence and WPML performancs problem’ is closed to new replies.