Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14398

    Hey im having a bit of problem getting the comment section in posts to show up.

    I have made sure the discussion options are checked on the pages and posts however it doesn’t seem to do anything.

    Any help would be great.

    http://www.nzsnatch.com

    #83302

    Hello,

    Open up single.php and find this code.

    //show related posts based on tags if there are any
    get_template_part( 'includes/related-posts');

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    Make sure that the comments_template is there. if not place it below the get_template_part function.

    Regards,

    Ismael

    #83304

    that’s exactly how it was….

    #83305

    I am actually wanting to change to facebook comments but before I can start I need the others to show up.

    #83306

    Hello,

    When you means posts, you are referring to the News page? Did you change anything on the theme files? By default there should be a comment section on each posts.

    Regards,

    Ismael

    #83307

    Ok so I managed to get the comments to show up. (Problem was with my wp permalinks)

    Now I just have 2 questions.

    1. What is the best way for me to remove/disable the wp comment section. (want to remove everything under facebook comments http://nzsnatch.com/car-hunting/you-probably-didnt-know/ )

    2. How can I remove/edit the div.three.units.alpha.blog.meta.meta-color (loctated on both the blog and single post. Just want text full width.)

    Details.

    <div class=”fb-comments” data-href=”http://example.com” data-num-posts=”2″ data-width=”470″></div> was placed under this line <div class=’comment-entry post-entry’> in comments.php (Only place I found that would let it show up.)

    #83308

    Hi 2simpl,

    To hide the WP comments, try unchecking the to checkboxes in the “Discussion” section on all existing posts then going to Settings > Discussion and unchecking “Allow people to post comments on new articles”. I’m not sure if that will affect the Facebook Comments or not but that should disable comments.

    If for some reason that doesn’t work then add this to your custom.css or Quick CSS:

    To hide the WordPress comments:

    .comment_meta_container,
    .comment_container { display: none; }

    Now to hide the the blog meta simply add this in your custom.css or Quick CSS:

    .blog-meta { display: none; }

    Regards,

    Mya

    Edited: To include the . before the class names. :)

    #83309

    Just used the css, worked perfect just needed to add the . to show the class.

    Thanks for your help.

    #83310

    Hey!

    Glad that Mya could help you :)

    Regards,

    Peter

    #83311

    Hello,

    the comments do not show up when the permalinks are set to “%postname%/” (Postname).

    Whats going wrong here and how to fix it?

    Thanks alot

    Kugelblitz

    #83312

    Hi Kugelblitz,

    What you’re describing is different than this particular thread so if you don’t mind just so we don’t get confused could you start a new thread? Also, answer these questions for me. Were the comments showing up before you switched permalinks? Do the comments return once you switch to say Month and Name?

    Thanks!

    Regards,

    Mya

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Comment are hidden’ is closed to new replies.